zoukankan      html  css  js  c++  java
  • LITTLE SHOP OF FLOWERS_DP

    Time Limit: 1000MS   Memory Limit: 10000K
    Total Submissions: 20802   Accepted: 9613

    Description

    You want to arrange the window of your flower shop in a most pleasant way. You have F bunches of flowers, each being of a different kind, and at least as many vases ordered in a row. The vases are glued onto the shelf and are numbered consecutively 1 through V, where V is the number of vases, from left to right so that the vase 1 is the leftmost, and the vase V is the rightmost vase. The bunches are moveable and are uniquely identified by integers between 1 and F. These id-numbers have a significance: They determine the required order of appearance of the flower bunches in the row of vases so that the bunch i must be in a vase to the left of the vase containing bunch j whenever i < j. Suppose, for example, you have bunch of azaleas (id-number=1), a bunch of begonias (id-number=2) and a bunch of carnations (id-number=3). Now, all the bunches must be put into the vases keeping their id-numbers in order. The bunch of azaleas must be in a vase to the left of begonias, and the bunch of begonias must be in a vase to the left of carnations. If there are more vases than bunches of flowers then the excess will be left empty. A vase can hold only one bunch of flowers. 

    Each vase has a distinct characteristic (just like flowers do). Hence, putting a bunch of flowers in a vase results in a certain aesthetic value, expressed by an integer. The aesthetic values are presented in a table as shown below. Leaving a vase empty has an aesthetic value of 0. 
     

    V A S E S

    1

    2

    3

    4

    5

    Bunches

    1 (azaleas)

    7 23 -5 -24 16

    2 (begonias)

    5 21 -4 10 23

    3 (carnations)

    -21

    5 -4 -20 20

    According to the table, azaleas, for example, would look great in vase 2, but they would look awful in vase 4. 

    To achieve the most pleasant effect you have to maximize the sum of aesthetic values for the arrangement while keeping the required ordering of the flowers. If more than one arrangement has the maximal sum value, any one of them will be acceptable. You have to produce exactly one arrangement. 

    Input

    • The first line contains two numbers: FV.
    • The following F lines: Each of these lines contains V integers, so that Aij is given as the jthnumber on the (i+1)st line of the input file.


    • 1 <= F <= 100 where F is the number of the bunches of flowers. The bunches are numbered 1 through F. 
    • F <= V <= 100 where V is the number of vases. 
    • -50 <= Aij <= 50 where Aij is the aesthetic value obtained by putting the flower bunch i into the vase j.

    Output

    The first line will contain the sum of aesthetic values for your arrangement.

    Sample Input

    3 5
    7 23 -5 -24 16
    5 21 -4 10 23
    -21 5 -4 -20 20

    Sample Output

    53

    【题意】m*n个数,取m个数使加起来的数和最大,但要满足当前这行取得数的列数比前一行取得数的列数大

    【思路】dp[i][j]=max(dp[i][j-1],dp[i-1][j-1]+mp[i][j]);

    #include<iostream>
    #include<stdio.h>
    #include<string.h>
    using namespace std;
    const int N=150;
    int mp[N][N];
    int dp[N][N];
    int m,n;
    
    int main()
    {
        while(~scanf("%d%d",&m,&n))
        {
            memset(dp,0,sizeof(dp));
            for(int i=1;i<=m;i++)
            {
                for(int j=1;j<=n;j++)
                {
                    scanf("%d",&mp[i][j]);
                }
            }
            for(int i=1;i<=m;i++)//开始没写,一直wa
                dp[i][i]=dp[i-1][i-1]+mp[i][i];
            for(int i=1;i<=m;i++)
            {
                for(int j=i+1;j<=n;j++)
                {
                    dp[i][j]=max(dp[i][j-1],dp[i-1][j-1]+mp[i][j]);
                }
            }
            cout<<dp[m][n]<<endl;
        }
        return 0;
    }
  • 相关阅读:
    深入字节码 -- 计算方法执行时间
    RubyCritic:一款不错的检测代码质量工具
    云告警平台 OneAlert :如何帮助运维工程师做好汇报?
    企业应用程序安全的新「守护神」
    另辟蹊径:云计算给企业带来的4个好处
    年度十佳 DevOps 博客文章(后篇)
    自定义 Lint 规则简介
    静态分析安全测试(SAST)优缺点探析
    css添加了原始滚动条要隐藏滚动条的显示
    jquery实现图片切换
  • 原文地址:https://www.cnblogs.com/iwantstrong/p/5833448.html
Copyright © 2011-2022 走看看