zoukankan      html  css  js  c++  java
  • HDU 1073 Online Judge

    Online Judge

    http://www.cnblogs.com/kuangbin/archive/2012/10/28/2743788.html

    Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others) Total Submission(s): 3589    Accepted Submission(s): 1349

    Problem Description
    Ignatius is building an Online Judge, now he has worked out all the problems except the Judge System. The system has to read data from correct output file and user's result file, then the system compare the two files. If the two files are absolutly same, then the Judge System return "Accepted", else if the only differences between the two files are spaces(' '), tabs('\t'), or enters('\n'), the Judge System should return "Presentation Error", else the system will return "Wrong Answer".
    Given the data of correct output file and the data of user's result file, your task is to determine which result the Judge System will return.
     
    Input
    The input contains several test cases. The first line of the input is a single integer T which is the number of test cases. T test cases follow. Each test case has two parts, the data of correct output file and the data of the user's result file. Both of them are starts with a single line contains a string "START" and end with a single line contains a string "END", these two strings are not the data. In other words, the data is between the two strings. The data will at most 5000 characters.
     
    Output
    For each test cases, you should output the the result Judge System should return.
     
    Sample Input
     
    4
    START
    1 + 2 = 3
    END
    START
    1+2=3
    END
    START
    1 + 2 = 3
    END
    START
    1 + 2 = 3
     
    END
    START
    1 + 2 = 3
    END
    START
    1 + 2 = 4
    END
    START
    1 + 2 = 3
    END
    START
    1 + 2 = 3
    END
     
    Sample Output
     
    Presentation Error
    Presentation Error
    Wrong Answer
    Presentation Error
     
    Author
    Ignatius.L
     
     
     
    #include<stdio.h>
    #include<string.h>
    
    #define N 5050
    
    char a1[N],b1[N];
    char a2[N],b2[N];
    char tmp[N];
    
    void input(char *a,char *b){
        gets(tmp);
        while(strcmp(tmp,"START")!=0)
            gets(tmp);
        while(gets(tmp)){
            if(strcmp(tmp,"END")==0)
                break;
            if(strlen(tmp)!=0)
                strcat(a,tmp);
            strcat(a,"\n");
        }
        int t=0,len=strlen(a);
        for(int i=0;i<len;i++)
            if(a[i]!=' ' && a[i]!='\t' && a[i]!='\n')
                b[t++]=a[i];
        b[t]='\0';
    }
    
    int main(){
        int n;
        scanf("%d",&n);
        while(n--){
            a1[0]='\0';
            a2[0]='\0';
            input(a1,b1);
            input(a2,b2);
            if(strcmp(a1,a2)==0)
                printf("Accepted\n");
            else if(strcmp(b1,b2)==0)
                printf("Presentation Error\n");
            else
                printf("Wrong Answer\n");
        }
        return 0;
    }
  • 相关阅读:
    文件操作
    通过类型断言获取error类型,获得更详细的信息

    数组
    使用unsafe改善性能
    使用unsafe.Pointer将结构体转为[]byte
    (GoRails)链接link_to到当前页current Page 并使用参数 (类ActionController::Parameters)
    用ActionController::Renderer的render方法渲染模版
    innerHTML用法及错误:无法设置未定义或null引用的属性“innerHTML”解决
    ActionCable的部署(参考Gorails)
  • 原文地址:https://www.cnblogs.com/jackge/p/2835291.html
Copyright © 2011-2022 走看看