zoukankan      html  css  js  c++  java
  • HDU 4278 Faulty Odometer

    Faulty Odometer

    http://acm.hdu.edu.cn/showproblem.php?pid=4278

    Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others) Total Submission(s): 725    Accepted Submission(s): 512

    Problem Description
      You are given a car odometer which displays the miles traveled as an integer. The odometer has a defect, however: it proceeds from the digit 2 to the digit 4 and from the digit 7 to the digit 9, always skipping over the digit 3 and 8. This defect shows up in all positions (the one's, the ten's, the hundred's, etc.). For example, if the odometer displays 15229 and the car travels one mile, odometer reading changes to 15240 (instead of 15230).
     
    Input
      Each line of input contains a positive integer in the range 1..999999999 which represents an odometer reading. (Leading zeros will not appear in the input.) The end of input is indicated by a line containing a single 0. You may assume that no odometer reading will contain the digit 3 and 8.
     
    Output
      Each line of input will produce exactly one line of output, which will contain: the odometer reading from the input, a colon, one blank space, and the actual number of miles traveled by the car.
     
    Sample Input
     
    15
    2005
    250
    1500
    999999
    0
     
    Sample Output
     
    15: 12
    2005: 1028
    250: 160
    1500: 768
    999999: 262143
     
    Source
     
    Recommend
    liuyiding
     
     
    类似于8进制转化为10进制
     
    #include<stdio.h>
    
    int num[20],cnt;
    
    void change(int x){
        cnt=0;
        while(x){
            num[cnt++]=x%10;
            x/=10;
        }
        for(int i=0;i<cnt;i++)
            if(num[i]>=9)
                num[i]-=2;
            else if(num[i]>=4)
                num[i]-=1;
    }
    
    int main(){
        int n;
        while(scanf("%d",&n) && n){
            int ans=0;
            change(n);
            for(int i=cnt-1;i>=0;i--)
                ans=ans*8+num[i];
            printf("%d: %d\n",n,ans);
        }
        return 0;
    }
  • 相关阅读:
    HDU 4123 Bob’s Race 树的直径+ST表
    acm 2015北京网络赛 F Couple Trees 树链剖分+主席树
    acm java入门(转载)
    java水题集
    南昌网络赛C.Angry FFF Party
    eclipse 安装
    eclipse jdk安装
    树链剖分总结
    P
    L
  • 原文地址:https://www.cnblogs.com/jackge/p/2837073.html
Copyright © 2011-2022 走看看