zoukankan      html  css  js  c++  java
  • HDU 1943 Ball bearings

    Ball bearings

    http://acm.hdu.edu.cn/showproblem.php?pid=1943

    Time Limit: 5000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others) Total Submission(s): 43    Accepted Submission(s): 22

    Problem Description
    The Swedish company SKF makes ball bearings. As explained by Britannica Online, a ball bearing is “one of the two types of rolling, or anti friction, bearings (the other is the roller bearing).
    Its function is to connect two machine members that move relative to one another so that the frictional resistance to motion is minimal. In many applications, one of the members is a rotating shaft and the other a fixed housing. Each ball bearing has three main parts: two grooved, ring like races and a number of balls. The balls fill the space between the two races and roll with negligible friction in the grooves. The balls may be loosely restrained and separated by means of a retainer or cage.” Presumably, the more balls you have inside the outer ring, the smoother the ride will be, but how many can you t within the outer ring? You will be given the inner diameter of the outer ring, the diameter of the balls, and the minimum distance between neighboring balls. Your task is to compute the maximum number of balls that will t on the inside of the outer ring (all balls must touch the outer ring).
     
    Input
    The first line of input contains a positive integer n that indicates the number of test cases. Then follow n lines, each describing a test case. Each test case consists of three positive oating point numbers, D, d, s, where D is the inner diameter of the outer ring, d is the diameter of a ball, and s is the minimum distance between balls. All parameters are in the range [0.0001, 500.0].
     
    Output
    For each test case output a single integer m on a line by itself, where m is the maximum number of balls that can t in the ball bearing, given the above constraints. There will always be room for at least three balls.
     
    Sample Input
     
    2
    20 1 0.1
    100.0 13.0 0.2
     
    Sample Output
     
    54
    20
     
    Source
     
    Recommend
    wangye
     
     
    #include<iostream>
    #include<cstdio>
    #include<cmath>
    
    using namespace std;
    
    const double PI=acos(-1.0);     //圆周率PI
    
    int main(){
        int T;
        scanf("%d",&T);
        while(T--){
            double D,d,s;
            scanf("%lf%lf%lf",&D,&d,&s);
            double tmp=asin((d+s)/(D-d));
            double ans=(2*PI)/(2*tmp);
            printf("%d\n",(int)ans);
        }
        return 0;
    }
  • 相关阅读:
    深入理解javascript函数进阶系列第三篇——函数节流和函数防抖
    深入理解javascript函数进阶系列第二篇——函数柯里化
    深入理解javascript函数进阶系列第一篇——高阶函数
    javascript面向对象系列第四篇——OOP中的常见概念
    CSS以图换字的9种方法
    javascript面向对象系列第三篇——实现继承的3种形式
    使用gitbook
    linux云服务器常用设置
    Git要点
    Linux环境下安装NodeJS和mongoDB
  • 原文地址:https://www.cnblogs.com/jackge/p/2837842.html
Copyright © 2011-2022 走看看