zoukankan      html  css  js  c++  java
  • HDU 1698 Just a Hook

    Just a Hook

    http://acm.hdu.edu.cn/showproblem.php?pid=1698

    Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others) Total Submission(s): 10448    Accepted Submission(s): 5161

    Problem Description
    In the game of DotA, Pudge’s meat hook is actually the most horrible thing for most of the heroes. The hook is made up of several consecutive metallic sticks which are of the same length.
    Now Pudge wants to do some operations on the hook.
    Let us number the consecutive metallic sticks of the hook from 1 to N. For each operation, Pudge can change the consecutive metallic sticks, numbered from X to Y, into cupreous sticks, silver sticks or golden sticks. The total value of the hook is calculated as the sum of values of N metallic sticks. More precisely, the value for each kind of stick is calculated as follows:
    For each cupreous stick, the value is 1. For each silver stick, the value is 2. For each golden stick, the value is 3.
    Pudge wants to know the total value of the hook after performing the operations. You may consider the original hook is made up of cupreous sticks.
     
    Input
     
    The input consists of several test cases. The first line of the input is the number of the cases. There are no more than 10 cases. For each case, the first line contains an integer N, 1<=N<=100,000, which is the number of the sticks of Pudge’s meat hook and the second line contains an integer Q, 0<=Q<=100,000, which is the number of the operations. Next Q lines, each line contains three integers X, Y, 1<=X<=Y<=N, Z, 1<=Z<=3, which defines an operation: change the sticks numbered from X to Y into the metal kind Z, where Z=1 represents the cupreous kind, Z=2 represents the silver kind and Z=3 represents the golden kind.
     
    Output
     
    For each case, print a number in a line representing the total value of the hook after the operations. Use the format in the example.
     
    Sample Input
     
    1
    10
    2
    1 5 2
    5 9 3
     
    Sample Output
     
    Case 1: The total value of the hook is 24.
     
    Source
     
    Recommend
    wangye
     
     
     
    成端更新
     
    #include<iostream>
    #include<cstdio>
    
    using namespace std;
    
    #define lson l,mid,rt<<1
    #define rson mid+1,r,rt<<1|1
    
    const int maxn=100005;
    int n,m;
    int sum[maxn<<2],col[maxn<<2];
    
    void Push_Up(int rt){
        sum[rt]=sum[rt<<1]+sum[rt<<1|1];
    }
    
    void Push_Down(int rt,int m){
        if(col[rt]){
            col[rt<<1]=col[rt<<1|1]=col[rt];
            sum[rt<<1]=(m-(m>>1))*col[rt];
            sum[rt<<1|1]=(m>>1)*col[rt];
            col[rt]=0;
        }
    }
    
    void build(int l,int r,int rt){
        col[rt]=0;
        sum[rt]=1;
        if(l==r)
            return ;
        int mid=(l+r)>>1;
        build(lson);
        build(rson);
        Push_Up(rt);
    }
    
    void update(int L,int R,int c,int l,int r,int rt){
        if(L<=l && R>=r){
            col[rt]=c;
            sum[rt]=c*(r-l+1);
            return ;
        }
        Push_Down(rt,r-l+1);
        int mid=(l+r)>>1;
        if(L<=mid)
            update(L,R,c,lson);
        if(R>mid)
            update(L,R,c,rson);
        Push_Up(rt);
    }
    
    int main(){
        int t;
        scanf("%d",&t);
        int cases=0;
        while(t--){
            scanf("%d%d",&n,&m);
            build(1,n,1);
            int a,b,c;
            while(m--){
                scanf("%d%d%d",&a,&b,&c);
                update(a,b,c,1,n,1);
            }
            printf("Case %d: The total value of the hook is %d.\n",++cases,sum[1]);
        }
        return 0;
    }
  • 相关阅读:
    JavaScript小技巧总结
    Table边框使用总结 ,只显示你要显示的边框
    连续字符换行及单行溢出点点点显示
    对ThreadLocal的理解个人
    Linux面试题答案解析
    com.fasterxml.jackson.databind.JsonMappingException: No serializer found for class
    21道 Redis 常见面试题,必须掌握!
    MyBatis中的#与$
    Linux下zookeeper的搭建
    web.xml加载顺序与过程
  • 原文地址:https://www.cnblogs.com/jackge/p/2847316.html
Copyright © 2011-2022 走看看