zoukankan      html  css  js  c++  java
  • POJ 3628 Bookshelf 2

    Bookshelf 2

    http://acm.hdu.edu.cn/webcontest/contest_showproblem.php?pid=1002&ojid=1&cid=2967&hide=0

    Time Limit : 2000/1000ms (Java/Other)   Memory Limit : 131072/65536K (Java/Other)
    Total Submission(s) : 76   Accepted Submission(s) : 37
    Problem Description

    Farmer John recently bought another bookshelf for the cow library, but the shelf is getting filled up quite quickly, and now the only available space is at the top.

    FJ has N cows (1 ≤ N ≤ 20) each with some height of Hi (1 ≤ Hi ≤ 1,000,000 - these are very tall cows). The bookshelf has a height of B (1 ≤ BS, where S is the sum of the heights of all cows).

    To reach the top of the bookshelf, one or more of the cows can stand on top of each other in a stack, so that their total height is the sum of each of their individual heights. This total height must be no less than the height of the bookshelf in order for the cows to reach the top.

    Since a taller stack of cows than necessary can be dangerous, your job is to find the set of cows that produces a stack of the smallest height possible such that the stack can reach the bookshelf. Your program should print the minimal 'excess' height between the optimal stack of cows and the bookshelf.

     
    Input

    * Line 1: Two space-separated integers: N and B
    * Lines 2..N+1: Line i+1 contains a single integer: Hi

     
    Output

    * Line 1: A single integer representing the (non-negative) difference between the total height of the optimal set of cows and the height of the shelf.

     
    Sample Input
     
    5 16
    3
    1
    3
    5
    6
     
    Sample Output
     
    1
     
    Source
    PKU
     
     
    #include<iostream>
    #include<cstdio>
    #include<cstring>
    
    using namespace std;
    
    const int INF=0x3f3f3f3f;
    
    int n,b;
    int cow[30];
    int dp[20000010];
    
    int main(){
    
        //freopen("input.txt","r",stdin);
    
        while(~scanf("%d%d",&n,&b)){
            int sum=0;
            for(int i=0;i<n;i++){
                scanf("%d",&cow[i]);
                sum+=cow[i];
            }
            for(int i=0;i<=sum;i++) //若使用memset则会导致内存超出限制
                dp[i]=0;
            for(int i=0;i<n;i++)
                for(int j=sum;j>=cow[i];j--)
                    if(dp[j]<dp[j-cow[i]]+cow[i])
                        dp[j]=dp[j-cow[i]]+cow[i];
    
    
            int ans=INF;
            for(int i=b;i<=sum;i++)
                if(dp[i]>=b){
                    ans=dp[i]-b;
                    break;
                }
            printf("%d\n",ans);
        }
        return 0;
    }
  • 相关阅读:
    hiho_1081_最短路径1
    hiho_1079_离散化
    hiho_1078_线段树区间修改
    hiho_1069_最近公共祖先3
    【.netcore学习】.netcore添加到 supervisor 守护进程自启动报错
    【.NetCore学习】ubuntu16.04 搭建.net core mvc api 运行环境
    【.NetCore学习】ASP.NET Core EF Core2.0 DB First现有数据库自动生成实体Context
    【vue基础学习】vue.js开发环境搭建
    【vue学习】vue中怎么引用laydate.js日期插件
    【年终总结】个人的2017年年终总结
  • 原文地址:https://www.cnblogs.com/jackge/p/2939656.html
Copyright © 2011-2022 走看看