zoukankan      html  css  js  c++  java
  • POJ 2398 Toy Storage

    Toy Storage
    Time Limit: 1000MS   Memory Limit: 65536K
    Total Submissions: 3024   Accepted: 1726

    Description

    Mom and dad have a problem: their child, Reza, never puts his toys away when he is finished playing with them. They gave Reza a rectangular box to put his toys in. Unfortunately, Reza is rebellious and obeys his parents by simply throwing his toys into the box. All the toys get mixed up, and it is impossible for Reza to find his favorite toys anymore. 
    Reza's parents came up with the following idea. They put cardboard partitions into the box. Even if Reza keeps throwing his toys into the box, at least toys that get thrown into different partitions stay separate. The box looks like this from the top: 

    We want for each positive integer t, such that there exists a partition with t toys, determine how many partitions have t, toys.

    Input

    The input consists of a number of cases. The first line consists of six integers n, m, x1, y1, x2, y2. The number of cardboards to form the partitions is n (0 < n <= 1000) and the number of toys is given in m (0 < m <= 1000). The coordinates of the upper-left corner and the lower-right corner of the box are (x1, y1) and (x2, y2), respectively. The following n lines each consists of two integers Ui Li, indicating that the ends of the ith cardboard is at the coordinates (Ui, y1) and (Li, y2). You may assume that the cardboards do not intersect with each other. The next m lines each consists of two integers Xi Yi specifying where the ith toy has landed in the box. You may assume that no toy will land on a cardboard. 

    A line consisting of a single 0 terminates the input.

    Output

    For each box, first provide a header stating "Box" on a line of its own. After that, there will be one line of output per count (t > 0) of toys in a partition. The value t will be followed by a colon and a space, followed the number of partitions containing t toys. Output will be sorted in ascending order of t for each box.

    Sample Input

    4 10 0 10 100 0
    20 20
    80 80
    60 60
    40 40
    5 10
    15 10
    95 10
    25 10
    65 10
    75 10
    35 10
    45 10
    55 10
    85 10
    5 6 0 10 60 0
    4 3
    15 30
    3 1
    6 8
    10 10
    2 1
    2 8
    1 5
    5 5
    40 10
    7 9
    0
    

    Sample Output

    Box
    2: 5
    Box
    1: 4
    2: 1
    

    Source

     
     
     
    #include<iostream>
    #include<algorithm>
    #include<cstdio>
    #include<cstring>
    #include<cmath>
    
    using namespace std;
    
    struct point{
        double x,y;
    };
    
    double xmult(point &a,point &b,point &c){
        return (a.x-c.x)*(b.y-c.y)-(b.x-c.x)*(a.y-c.y);
    }
    
    struct line{
        point a,b;
    }l[5010];
    
    int n,m;
    int counts[5010];
    double X1,Y1,X2,Y2;
    
    int cmp(line s,line t){
        if(s.a.x!=t.a.x)
            return s.a.x<t.a.x;
        return s.b.x<t.b.x;
    }
    
    int binarySearch(point &p){
        int low=0,high=n,mid;
        while(low<=high){
            mid=(low+high)>>1;
            if(xmult(l[mid].a,l[mid].b,p)>0)
                low=mid+1;
            else
                high=mid-1;
        }
        return high+1;
    }
    
    int main(){
    
        //freopen("input.txt","r",stdin);
    
        while(cin>>n && n){
            cin>>m>>X1>>Y1>>X2>>Y2;
            memset(counts,0,sizeof(counts));
            for(int i=0;i<n;i++){
                cin>>l[i].a.x>>l[i].b.x;
                l[i].a.y=Y1;
                l[i].b.y=Y2;
            }
            l[n].a.x=X2;
            l[n].a.y=Y1;
            l[n].b.x=X2;
            l[n].b.y=Y2;
            sort(l,l+n+1,cmp);
    
            point toy;
            for(int i=0;i<m;i++){
                cin>>toy.x>>toy.y;
                int j=binarySearch(toy);
                counts[j]++;
            }
    
            int hash[1010]={0};
            for(int i=0;i<=n;i++)
                hash[counts[i]]++;
            cout<<"Box"<<endl;
            for(int i=1;i<=n;i++)
                if(hash[i])
                    cout<<i<<": "<<hash[i]<<endl;
        }
        return 0;
    }
  • 相关阅读:
    求助:C#读文本文件(编码未知)的问题
    求助:字符的显示问题
    常用的xml文件操作
    关于旧表导入新表的数据冲突问题
    通过批处理管理安装windows服务
    windows服务,批处理安装
    ajax的请求的超时处理
    消息队列的使用
    c#程序执行cmd命令
    dynamic(翻译)
  • 原文地址:https://www.cnblogs.com/jackge/p/2952320.html
Copyright © 2011-2022 走看看