zoukankan      html  css  js  c++  java
  • HDU Fire Net

    Fire Net

    Time Limit : 2000/1000ms (Java/Other)   Memory Limit : 65536/32768K (Java/Other)
    Total Submission(s) : 1   Accepted Submission(s) : 1

    Font: Times New Roman | Verdana | Georgia

    Font Size:  

    Problem Description

    Suppose that we have a square city with straight streets. A map of a city is a square board with n rows and n columns, each representing a street or a piece of wall. 
    A blockhouse is a small castle that has four openings through which to shoot. The four openings are facing North, East, South, and West, respectively. There will be one machine gun shooting through each opening. 
    Here we assume that a bullet is so powerful that it can run across any distance and destroy a blockhouse on its way. On the other hand, a wall is so strongly built that can stop the bullets. 
    The goal is to place as many blockhouses in a city as possible so that no two can destroy each other. A configuration of blockhouses is legal provided that no two blockhouses are on the same horizontal row or vertical column in a map unless there is at least one wall separating them. In this problem we will consider small square cities (at most 4x4) that contain walls through which bullets cannot run through. 
    The following image shows five pictures of the same board. The first picture is the empty board, the second and third pictures show legal configurations, and the fourth and fifth pictures show illegal configurations. For this board, the maximum number of blockhouses in a legal configuration is 5; the second picture shows one way to do it, but there are several other ways. 

    Your task is to write a program that, given a description of a map, calculates the maximum number of blockhouses that can be placed in the city in a legal configuration. 

    Input

    The input file contains one or more map descriptions, followed by a line containing the number 0 that signals the end of the file. Each map description begins with a line containing a positive integer n that is the size of the city; n will be at most 4. The next n lines each describe one row of the map, with a '.' indicating an open space and an uppercase 'X' indicating a wall. There are no spaces in the input file. 

    Output

    For each test case, output one line containing the maximum number of blockhouses that can be placed in the city in a legal configuration.

    Sample Input

    4
    .X..
    ....
    XX..
    ....
    2
    XX
    .X
    3
    .X.
    X.X
    .X.
    3
    ...
    .XX
    .XX
    4
    ....
    ....
    ....
    ....
    0
    

    Sample Output

    5
    1
    5
    2
    4
    

    Source

    Zhejiang University Local Contest 2001
     
     
    #include<iostream>
    #include<cstdio>
    
    using namespace std;
    
    int map[5][5],n,ans,m;
    int visited[5][5],flag;
    
    void DFS(int s){
        if(s==n*n){
            if(ans<m)
                ans=m;
            return;
        }
        int i,j,k;
        i=s/n,j=s%n;
        if(!visited[i][j]){
            flag=0;
            if(map[i][j])
                flag=1;
            for(k=i-1;k>=0 && !flag;k--){
                if(map[k][j])
                    break;
                if(visited[k][j]){
                    flag=1;
                    break;
                }
            }
            for(k=j-1;k>=0 && !flag;k--){
                if(map[i][k])
                    break;
                if(visited[i][k]){
                    flag=1;
                    break;
                }
            }
            if(!flag){
                m++;
                visited[i][j]=1;
                DFS(s+1);
                m--;
                visited[i][j]=0;
                DFS(s+1);
            }else
                DFS(s+1);
        }
    }
    
    int main(){
    
        //freopen("input.txt","r",stdin);
    
        char ch;
        while(cin>>n && n){
            ans=m=0;
            for(int i=0;i<n;i++)
                for(int j=0;j<n;j++){
                    cin>>ch;
                    map[i][j]=(ch=='X');
                    visited[i][j]=0;
                }
            DFS(0);
            printf("%d\n",ans);
        }
        return 0;
    }
  • 相关阅读:
    sql 生成javabean实体
    git 安装 使用过程遇到的问题
    CentOS7 ab压力测试安装
    Lvs+keepalived+mysql(主从复制)
    liunx下tomcat启动 Cannot find ./catalina.sh
    ftp和ssh登录缓慢的解决办法
    Contos7 FTP 安装步骤
    python生成100以内格式化的数
    Windows中更新python模块的命令
    scrapy的User-Agent中间件、代理IP中间件、cookies设置、多个爬虫自定义settings设置
  • 原文地址:https://www.cnblogs.com/jackge/p/2962550.html
Copyright © 2011-2022 走看看