zoukankan      html  css  js  c++  java
  • HDU Tempter of the Bone

    Tempter of the Bone

    Time Limit : 2000/1000ms (Java/Other)   Memory Limit : 65536/32768K (Java/Other)
    Total Submission(s) : 3   Accepted Submission(s) : 1

    Font: Times New Roman | Verdana | Georgia

    Font Size:  

    Problem Description

    The doggie found a bone in an ancient maze, which fascinated him a lot. However, when he picked it up, the maze began to shake, and the doggie could feel the ground sinking. He realized that the bone was a trap, and he tried desperately to get out of this maze.
    The maze was a rectangle with sizes N by M. There was a door in the maze. At the beginning, the door was closed and it would open at the T-th second for a short period of time (less than 1 second). Therefore the doggie had to arrive at the door on exactly the T-th second. In every second, he could move one block to one of the upper, lower, left and right neighboring blocks. Once he entered a block, the ground of this block would start to sink and disappear in the next second. He could not stay at one block for more than one second, nor could he move into a visited block. Can the poor doggie survive? Please help him.

    Input

    The input consists of multiple test cases. The first line of each test case contains three integers N, M, and T (1 < N, M < 7; 0 < T < 50), which denote the sizes of the maze and the time at which the door will open, respectively. The next N lines give the maze layout, with each line containing M characters. A character is one of the following:
    'X': a block of wall, which the doggie cannot enter;  'S': the start point of the doggie;  'D': the Door; or '.': an empty block.
    The input is terminated with three 0's. This test case is not to be processed.

    Output

    For each test case, print in one line "YES" if the doggie can survive, or "NO" otherwise.

    Sample Input

    4 4 5
    S.X.
    ..X.
    ..XD
    ....
    3 4 5
    S.X.
    ..X.
    ...D
    0 0 0
    

    Sample Output

    NO
    YES
    

    Author

    ZHANG, Zheng

    Source

    ZJCPC2004
     
     
    #include<iostream>
    #include<cstdio>
    #include<cstring>
    
    using namespace std;
    
    char map[10][10];
    int n,m,t;
    int visited[10][10];
    int flag,sx,sy,ex,ey;
    
    int dir[4][2]={{1,0},{0,-1},{-1,0},{0,1}};
    
    int abs(int a){
        return a<0?-a:a;
    }
    
    void DFS(int x,int y,int c){
        if(flag || (x==ex && y==ey && c==t)){
            flag=1;
            return ;
        }
        if(x<0 || x>=n || y<0 || y>=m || c>=t)
            return ;
        int tmp=abs(ex-x)+abs(ey-y);
        tmp=t-tmp-c;
        if(tmp&1)
            return ;
        for(int i=0;i<4;i++){
            int tx=x+dir[i][0],ty=y+dir[i][1];
            if(!visited[tx][ty] && map[tx][ty]!='X'){
                visited[tx][ty]=1;
                DFS(tx,ty,c+1);
                visited[tx][ty]=0;
            }
        }
    }
    
    int main(){
    
        //freopen("input.txt","r",stdin);
    
        while(cin>>n>>m>>t){
            if(n==0 && m==0 && t==0)
                break;
            int i,j;
            int cnt=0;
            memset(visited,0,sizeof(visited));
            for(i=0;i<n;i++)
                for(j=0;j<m;j++){
                    cin>>map[i][j];
                    if(map[i][j]=='S'){
                        sx=i;sy=j;
                        visited[i][j]=1;
                    }
                    if(map[i][j]=='D'){
                        ex=i;ey=j;
                    }
                    if(map[i][j]=='X')
                        cnt++;
                }
            flag=0;
            if(n*m-1-cnt>=t)
                DFS(sx,sy,0);
            if(flag)
                printf("YES\n");
            else
                printf("NO\n");
    
        }
        return 0;
    }
  • 相关阅读:
    Codeforces Round #213 (Div. 2) B. The Fibonacci Segment
    关于求解不定方程的n(n-1)=2m(m-1)的解法的总结
    objective-c @()
    objective-c 条件运算符
    关于判断两个矩阵相交的一点想法
    二维几何常用运算
    《为ipad而设计 打造畅销APP》读书笔记
    ios cocos2d FPS过低的解决方法
    python 根据对象和方法名,返回提供这个方法的定义的类
    python 获取类的属性
  • 原文地址:https://www.cnblogs.com/jackge/p/2971417.html
Copyright © 2011-2022 走看看