zoukankan      html  css  js  c++  java
  • HDU 2830 Matrix Swapping II

    Matrix Swapping II

    Time Limit: 9000/3000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others) Total Submission(s): 793    Accepted Submission(s): 537

    Problem Description
    Given an N * M matrix with each entry equal to 0 or 1. We can find some rectangles in the matrix whose entries are all 1, and we define the maximum area of such rectangle as this matrix’s goodness. 
    We can swap any two columns any times, and we are to make the goodness of the matrix as large as possible.
     
    Input
    There are several test cases in the input. The first line of each test case contains two integers N and M (1 ≤ N,M ≤ 1000). Then N lines follow, each contains M numbers (0 or 1), indicating the N * M matrix
     
    Output
    Output one line for each test case, indicating the maximum possible goodness.
     
    Sample Input
    3 4
    1011
    1001
    0001
    3 4
    1010
    1001
    0001
     
    Sample Output
    4
    2
     
    Note: Huge Input, scanf() is recommended.
     
    Source
     
    Recommend
    gaojie
     
     
     

    对每一行进行处理然后再叠加,到每一行用num[i]记下到这一行有多少个1

     

    例如:

     

    1 0 1 1          num[i]的记录就是: 1 0 1 1                    

     

    1 0 0 1                             2 0 0 2         

     

    0 0 0 1                             0 0 0 3

     

    然后对num[i]从大到小排一下,求出读取到当前行能够得到的最大面积。

     

    也就是最右边放着最多的1,依次类推。那么当前最大的面积就是 MAXmax,num[i]*i)了

     

     

     

    #include<iostream>
    #include<algorithm>
    #include<cstdio>
    #include<cstring>
    
    using namespace std;
    
    const int maxn=1010;
    
    int num[maxn],row[maxn];
    
    int cmp(int a,int b){
        return a>b;
    }
    
    int main(){
    
        //freopen("input.txt","r",stdin);
    
        int n,m;
        while(scanf("%d%d",&n,&m)!=EOF){
            getchar();
            memset(num,0,sizeof(num));
            int i,j,ans=0;
            char ch;
            for(i=1;i<=n;i++){
                for(j=1;j<=m;j++){
                    scanf("%c",&ch);
                    if(ch=='1')
                        num[j]++;
                    else
                        num[j]=0;
                    row[j]=num[j];
                }
                sort(row+1,row+m+1,cmp);
                for(j=1;j<=m;j++)
                    if(ans<row[j]*j)
                        ans=row[j]*j;
                getchar();
            }
            printf("%d\n",ans);
        }
        return 0;
    }

     

     

  • 相关阅读:
    图片预览神器
    近期错题总结
    鬼谷子的钱袋(lgP2320)
    小明的账单
    合并果子(lgP1090)
    看病
    稀有矿井
    舞会(lgP1352)
    三国风云
    天上掉 Pizza
  • 原文地址:https://www.cnblogs.com/jackge/p/2980811.html
Copyright © 2011-2022 走看看