zoukankan      html  css  js  c++  java
  • HDU 2830 Matrix Swapping II

    Matrix Swapping II

    Time Limit: 9000/3000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others) Total Submission(s): 793    Accepted Submission(s): 537

    Problem Description
    Given an N * M matrix with each entry equal to 0 or 1. We can find some rectangles in the matrix whose entries are all 1, and we define the maximum area of such rectangle as this matrix’s goodness. 
    We can swap any two columns any times, and we are to make the goodness of the matrix as large as possible.
     
    Input
    There are several test cases in the input. The first line of each test case contains two integers N and M (1 ≤ N,M ≤ 1000). Then N lines follow, each contains M numbers (0 or 1), indicating the N * M matrix
     
    Output
    Output one line for each test case, indicating the maximum possible goodness.
     
    Sample Input
    3 4
    1011
    1001
    0001
    3 4
    1010
    1001
    0001
     
    Sample Output
    4
    2
     
    Note: Huge Input, scanf() is recommended.
     
    Source
     
    Recommend
    gaojie
     
     
     

    对每一行进行处理然后再叠加,到每一行用num[i]记下到这一行有多少个1

     

    例如:

     

    1 0 1 1          num[i]的记录就是: 1 0 1 1                    

     

    1 0 0 1                             2 0 0 2         

     

    0 0 0 1                             0 0 0 3

     

    然后对num[i]从大到小排一下,求出读取到当前行能够得到的最大面积。

     

    也就是最右边放着最多的1,依次类推。那么当前最大的面积就是 MAXmax,num[i]*i)了

     

     

     

    #include<iostream>
    #include<algorithm>
    #include<cstdio>
    #include<cstring>
    
    using namespace std;
    
    const int maxn=1010;
    
    int num[maxn],row[maxn];
    
    int cmp(int a,int b){
        return a>b;
    }
    
    int main(){
    
        //freopen("input.txt","r",stdin);
    
        int n,m;
        while(scanf("%d%d",&n,&m)!=EOF){
            getchar();
            memset(num,0,sizeof(num));
            int i,j,ans=0;
            char ch;
            for(i=1;i<=n;i++){
                for(j=1;j<=m;j++){
                    scanf("%c",&ch);
                    if(ch=='1')
                        num[j]++;
                    else
                        num[j]=0;
                    row[j]=num[j];
                }
                sort(row+1,row+m+1,cmp);
                for(j=1;j<=m;j++)
                    if(ans<row[j]*j)
                        ans=row[j]*j;
                getchar();
            }
            printf("%d\n",ans);
        }
        return 0;
    }

     

     

  • 相关阅读:
    [bzoj3295][Cqoi2011][动态逆序对] (树套树)
    [bzoj3209][花神的数论题] (数位dp+费马小定理)
    [bzoj1026][SCOI2009][windy数] (数位dp)
    [bzoj4521][Cqoi2016][手机号码] (数位dp+记忆化搜索)
    [bzoj1833][ZJOI2010][count] (数位dp)
    [spoj1182][Sorted Bit Sequence] (数位dp)
    [ural1057][Amount of Degrees] (数位dp+进制模型)
    [hdu3652][B-number] (数位dp)
    【bzoj2523】【CTSC2001】聪明的学生
    友情链接(有的是单向的)
  • 原文地址:https://www.cnblogs.com/jackge/p/2980811.html
Copyright © 2011-2022 走看看