zoukankan      html  css  js  c++  java
  • HDU 1025 Constructing Roads In JGShining's Kingdom (DP+二分)

    Constructing Roads In JGShining's Kingdom

    Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others) Total Submission(s): 10441    Accepted Submission(s): 2990

    Problem Description
    JGShining's kingdom consists of 2n(n is no more than 500,000) small cities which are located in two parallel lines.
    Half of these cities are rich in resource (we call them rich cities) while the others are short of resource (we call them poor cities). Each poor city is short of exactly one kind of resource and also each rich city is rich in exactly one kind of resource. You may assume no two poor cities are short of one same kind of resource and no two rich cities are rich in one same kind of resource. 
    With the development of industry, poor cities wanna import resource from rich ones. The roads existed are so small that they're unable to ensure the heavy trucks, so new roads should be built. The poor cities strongly BS each other, so are the rich ones. Poor cities don't wanna build a road with other poor ones, and rich ones also can't abide sharing an end of road with other rich ones. Because of economic benefit, any rich city will be willing to export resource to any poor one.
    Rich citis marked from 1 to n are located in Line I and poor ones marked from 1 to n are located in Line II. 
    The location of Rich City 1 is on the left of all other cities, Rich City 2 is on the left of all other cities excluding Rich City 1, Rich City 3 is on the right of Rich City 1 and Rich City 2 but on the left of all other cities ... And so as the poor ones. 
    But as you know, two crossed roads may cause a lot of traffic accident so JGShining has established a law to forbid constructing crossed roads.
    For example, the roads in Figure I are forbidden.
    In order to build as many roads as possible, the young and handsome king of the kingdom - JGShining needs your help, please help him. ^_^
     
    Input
    Each test case will begin with a line containing an integer n(1 ≤ n ≤ 500,000). Then n lines follow. Each line contains two integers p and r which represents that Poor City p needs to import resources from Rich City r. Process to the end of file.
     
    Output
    For each test case, output the result in the form of sample.  You should tell JGShining what's the maximal number of road(s) can be built. 
     
    Sample Input
    2
    1 2
    2 1
    3
    1 2
    2 3
    3 1
     
    Sample Output
    Case 1:
    My king, at most 1 road can be built.
     
    Case 2:
    My king, at most 2 roads can be built.
     
    Hint
    Huge input, scanf is recommended.
     
    Author
    JGShining(极光炫影)
     
     
     
     
    #include<stdio.h>
    
    const int maxn=500010;
    
    int num[maxn],dp[maxn];
    
    int main(){
    
        //freopen("input.txt","r",stdin);
    
        int n,cases=0;
        while(scanf("%d",&n)!=EOF){
            int a,b;
            for(int i=0;i<n;i++){
                scanf("%d%d",&a,&b);
                num[a]=b;
            }
            int len=1;
            int left,right,mid;
            dp[1]=num[1];
            for(int i=2;i<=n;i++){
                left=0;
                right=len;
                while(left<=right){
                    mid=(left+right)>>1;
                    if(num[i]>dp[mid])
                        left=mid+1;
                    else
                        right=mid-1;
                }
                dp[left]=num[i];
                if(left>len)
                    len++;
            }
            printf("Case %d:\n",++cases);
            if(len==1)
                printf("My king, at most 1 road can be built.\n\n");
            else
                printf("My king, at most %d roads can be built.\n\n",len);
        }
        return 0;
    }
  • 相关阅读:
    面向对象和网络编程补充
    元类与网络编程
    类的继承
    面向过程
    身为一个小白,看到一篇值得看的文章。讲述小白学习python的6个方法。
    2019.08.02 学习整理
    2019.08.01学习整理
    2017.07.31 学习整理
    2019.07.30 学习整理
    2019.7.29学习整理python
  • 原文地址:https://www.cnblogs.com/jackge/p/2982781.html
Copyright © 2011-2022 走看看