zoukankan      html  css  js  c++  java
  • HDU 1250 Hat's Fibonacci

    Hat's Fibonacci

    Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others) Total Submission(s): 4547    Accepted Submission(s): 1544

    Problem Description
    A Fibonacci sequence is calculated by adding the previous two members the sequence, with the first two members being both 1. F(1) = 1, F(2) = 1, F(3) = 1,F(4) = 1, F(n>4) = F(n - 1) + F(n-2) + F(n-3) + F(n-4) Your task is to take a number as input, and print that Fibonacci number.
     
    Input
    Each line will contain an integers. Process to end of file.
     
    Output
    For each case, output the result in a line.
     
    Sample Input
    100
     
    Sample Output
    4203968145672990846840663646
     
    Note: No generated Fibonacci number in excess of 2005 digits will be in the test data, ie. F(20) = 66526 has 5 digits.
     
    Author
    戴帽子的
     
    Recommend
    Ignatius.L
     
     
     
     
     
    import java.util.*;
    import java.math.*;
    
    public class Main{
        public static void main(String[] args){
            Scanner cin = new Scanner(System.in);
            int n;
            while(cin.hasNext()){
                n = cin.nextInt();
                BigInteger a = BigInteger.valueOf(1);
                BigInteger b = BigInteger.valueOf(1);
                BigInteger c = BigInteger.valueOf(1);
                BigInteger d = BigInteger.valueOf(1);
                BigInteger e = BigInteger.valueOf(1);
                for(int i=5; i<=n; i++){
                    e = a.add(b.add(c.add(d)));
                    a = b;
                    b = c;
                    c = d;
                    d = e;
                }
                System.out.println(e);
            }
        }
    }
  • 相关阅读:
    软件课程设计(3)
    软件课程设计(2)
    软件课程设计(1)
    继往开来第五天
    勤勤恳恳第四天
    撸起袖子第三天
    厉兵秣马第二天
    项目初定第一天
    Magic-Club第五天
    Magic-Club第四天
  • 原文地址:https://www.cnblogs.com/jackge/p/2990055.html
Copyright © 2011-2022 走看看