zoukankan      html  css  js  c++  java
  • HDU 3342 Legal or Not

    Legal or Not

    Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others) Total Submission(s): 2672    Accepted Submission(s): 1191

    Problem Description
    ACM-DIY is a large QQ group where many excellent acmers get together. It is so harmonious that just like a big family. Every day,many "holy cows" like HH, hh, AC, ZT, lcc, BF, Qinz and so on chat on-line to exchange their ideas. When someone has questions, many warm-hearted cows like Lost will come to help. Then the one being helped will call Lost "master", and Lost will have a nice "prentice". By and by, there are many pairs of "master and prentice". But then problem occurs: there are too many masters and too many prentices, how can we know whether it is legal or not?
    We all know a master can have many prentices and a prentice may have a lot of masters too, it's legal. Nevertheless,some cows are not so honest, they hold illegal relationship. Take HH and 3xian for instant, HH is 3xian's master and, at the same time, 3xian is HH's master,which is quite illegal! To avoid this,please help us to judge whether their relationship is legal or not. 
    Please note that the "master and prentice" relation is transitive. It means that if A is B's master ans B is C's master, then A is C's master.
     
    Input
    The input consists of several test cases. For each case, the first line contains two integers, N (members to be tested) and M (relationships to be tested)(2 <= N, M <= 100). Then M lines follow, each contains a pair of (x, y) which means x is y's master and y is x's prentice. The input is terminated by N = 0. TO MAKE IT SIMPLE, we give every one a number (0, 1, 2,..., N-1). We use their numbers instead of their names.
     
    Output
    For each test case, print in one line the judgement of the messy relationship. If it is legal, output "YES", otherwise "NO".
     
    Sample Input
    3 2
    0 1
    1 2
    2 2
    0 1
    1 0
    0 0
     
    Sample Output
    YES
    NO
     
    Author
    QiuQiu@NJFU
     
    Source
     
    Recommend
    lcy
     
     
     
     
     
    #include<stdio.h>
    #include<string.h>
    
    const int maxn=120;
    
    int map[maxn][maxn],dg[maxn];
    int n,m,flag;
    
    int TopoSort(){
        int i,j,k;
        for(i=0;i<n;i++){
            int tmp=n;
            for(j=0;j<n;j++)
                if(dg[j]==0){
                    tmp=j;
                    dg[j]--;
                    break;
                }
            if(tmp==n)
                return 0;
            for(k=0;k<n;k++)
                if(map[tmp][k])
                    dg[k]--;
        }
        return 1;
    }
    
    int main(){
    
        //freopen("input.txt","r",stdin);
    
        while(scanf("%d%d",&n,&m)){
            if(n==0 && m==0)
                break;
            memset(map,0,sizeof(map));
            memset(dg,0,sizeof(dg));
            int a,b;
            for(int i=0;i<m;i++){
                scanf("%d%d",&a,&b);
                if(map[a][b]==0){
                    map[a][b]=1;
                    dg[b]++;
                }
            }
            flag=TopoSort();
            if(flag)
                printf("YES\n");
            else
                printf("NO\n");
        }
        return 0;
    }
  • 相关阅读:
    第三方包源码maven 下载
    Redis实现主从复制(转)
    Linq的优缺点
    async & await (转载)
    [转]抽象类与接口的区别及应用
    转载:C#中的泛型
    MVC导出数据到EXCEL新方法:将视图或分部视图转换为HTML后再直接返回FileResult
    C#中委托
    创建新的虚拟机
    GitHub上整理的一些工具[转载]
  • 原文地址:https://www.cnblogs.com/jackge/p/2990407.html
Copyright © 2011-2022 走看看