zoukankan      html  css  js  c++  java
  • HDU 3065 病毒侵袭持续中 (AC自动机)

    病毒侵袭持续中

    Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others) Total Submission(s): 3920    Accepted Submission(s): 1408

    Problem Description
    小t非常感谢大家帮忙解决了他的上一个问题。然而病毒侵袭持续中。在小t的不懈努力下,他发现了网路中的“万恶之源”。这是一个庞大的病毒网站,他有着好多好多的病毒,但是这个网站包含的病毒很奇怪,这些病毒的特征码很短,而且只包含“英文大写字符”。当然小t好想好想为民除害,但是小t从来不打没有准备的战争。知己知彼,百战不殆,小t首先要做的是知道这个病毒网站特征:包含多少不同的病毒,每种病毒出现了多少次。大家能再帮帮他吗?
     
    Input
    第一行,一个整数N(1<=N<=1000),表示病毒特征码的个数。 接下来N行,每行表示一个病毒特征码,特征码字符串长度在1—50之间,并且只包含“英文大写字符”。任意两个病毒特征码,不会完全相同。 在这之后一行,表示“万恶之源”网站源码,源码字符串长度在2000000之内。字符串中字符都是ASCII码可见字符(不包括回车)。
     
    Output
    按以下格式每行一个,输出每个病毒出现次数。未出现的病毒不需要输出。 病毒特征码: 出现次数 冒号后有一个空格,按病毒特征码的输入顺序进行输出。
     
    Sample Input
    3
    AA
    BB
    CC
    ooxxCC%dAAAoen....END
     
    Sample Output
    AA: 2
    CC: 1
    Hint
    Hit: 题目描述中没有被提及的所有情况都应该进行考虑。比如两个病毒特征码可能有相互包含或者有重叠的特征码段。 计数策略也可一定程度上从Sample中推测。
     
    Source
     
    Recommend
    lcy
     
     
     
     
     
    #include<iostream>
    #include<cstdio>
    #include<cstring>
    
    using namespace std;
    
    const int N=30;
    
    struct Trie{
        Trie *fail;
        Trie *next[N];
        int count;
        int id;
    
        Trie(){
            fail=NULL;
            count=0;
            id=-1;
            memset(next,NULL,sizeof(next));
        }
    }*q[500010];
    
    char word[1010][60];
    char str[2000010];
    int head,tail,ID;
    int vis[1010];
    
    void Insert(char *str,Trie *Root){
        Trie *loc=Root;
        int i=0;
        while(str[i]!='\0'){
            int id=str[i]-'A';
            if(loc->next[id]==NULL)
                loc->next[id]=new Trie();
            loc=loc->next[id];
            i++;
        }
        loc->count++;
        loc->id=ID++;
    }
    
    void AC_automation(Trie *Root){
        Root->fail=NULL;
        q[head++]=Root;
        Trie *cur,*tmp;
        while(head!=tail){
            cur=q[tail++];
            tmp=NULL;
            for(int i=0;i<30;i++){
                if(cur->next[i]!=NULL){
                    if(cur==Root)
                        cur->next[i]->fail=Root;
                    else{
                        tmp=cur->fail;
                        while(tmp!=NULL){
                            if(tmp->next[i]!=NULL){
                                cur->next[i]->fail=tmp->next[i];
                                break;
                            }
                            tmp=tmp->fail;
                        }
                        if(tmp==NULL)
                            cur->next[i]->fail=Root;
                    }
                    q[head++]=cur->next[i];
                }
            }
        }
    }
    
    void query(Trie *Root){
        int i=0;
        Trie *loc=Root,*tmp;
        while(str[i]!='\0'){
            int id=str[i]-'A';
            if(id<0 || id>26)
                id=27;
            while(loc->next[id]==NULL && loc!=Root)
                loc=loc->fail;
            loc=loc->next[id];
            loc=(loc==NULL)?Root:loc;
            tmp=loc;
            while(tmp!=Root){
                if(tmp->id!=-1)
                    vis[tmp->id]++;
                tmp=tmp->fail;
            }
            i++;
        }
    }
    
    int main(){
    
        //freopen("input.txt","r",stdin);
    
        int n;
        while(~scanf("%d",&n)){
            memset(vis,0,sizeof(vis));
            head=tail=0;
            ID=0;
            Trie *Root=new Trie();
            for(int i=0;i<n;i++){
                getchar();
                scanf("%s",word[i]);
                Insert(word[i],Root);
            }
            AC_automation(Root);
            getchar();
            scanf("%s",str);
            query(Root);
            for(int i=0;i<n;i++)
                if(vis[i])
                    printf("%s: %d\n",word[i],vis[i]);
        }
        return 0;
    }
  • 相关阅读:
    针对当前用户 对方法加锁
    二叉树
    return与析构续
    return与析构函数
    拷贝构造函数
    引用
    返回引用的函数值和参数的引用
    使用引用返回函数值
    邻接表--图 部分代码
    dec,hex and oct
  • 原文地址:https://www.cnblogs.com/jackge/p/2993553.html
Copyright © 2011-2022 走看看