zoukankan      html  css  js  c++  java
  • HDU 50 years, 50 colors

    50 years, 50 colors

    Time Limit : 2000/1000ms (Java/Other)   Memory Limit : 32768/32768K (Java/Other)
    Total Submission(s) : 12   Accepted Submission(s) : 8
    Problem Description
    On Octorber 21st, HDU 50-year-celebration, 50-color balloons floating around the campus, it's so nice, isn't it? To celebrate this meaningful day, the ACM team of HDU hold some fuuny games. Especially, there will be a game named "crashing color balloons".
    There will be a n*n matrix board on the ground, and each grid will have a color balloon in it.And the color of the ballon will be in the range of [1, 50].After the referee shouts "go!",you can begin to crash the balloons.Every time you can only choose one kind of balloon to crash, we define that the two balloons with the same color belong to the same kind.What's more, each time you can only choose a single row or column of balloon, and crash the balloons that with the color you had chosen. Of course, a lot of students are waiting to play this game, so we just give every student k times to crash the balloons.
    Here comes the problem: which kind of balloon is impossible to be all crashed by a student in k times.
     
    Input
    There will be multiple input cases.Each test case begins with two integers n, k. n is the number of rows and columns of the balloons (1 <= n <= 100), and k is the times that ginving to each student(0 < k <= n).Follow a matrix A of n*n, where Aij denote the color of the ballon in the i row, j column.Input ends with n = k = 0.
     
    Output
    For each test case, print in ascending order all the colors of which are impossible to be crashed by a student in k times. If there is no choice, print "-1".
     
    Sample Input
    1 1
    1
    2 1
    1 1
    1 2
    2 1
    1 2
    2 2
    5 4
    1 2 3 4 5
    2 3 4 5 1
    3 4 5 1 2
    4 5 1 2 3
    5 1 2 3 4
    3 3
    50 50 50
    50 50 50
    50 50 50
    0 0
     
    Sample Output
    -1
    1
    2
    1 2 3 4 5
    -1
     
    Author
    8600
     
    Source
    “2006校园文化活动月”之“校庆杯”大学生程序设计竞赛暨杭州电子科技大学第四届大学生程序设计竞赛
     
     
     
     
    #include<iostream>
    #include<cstdio>
    #include<cstring>
    #include<set>
    
    using namespace std;
    
    int num[120][120];
    int n,k,map[120][120],linker[120],vis[120];
    int res[60];
    set<int> st;
    
    int DFS(int u){
        int v;
        for(v=0;v<n;v++)
            if(map[u][v] && !vis[v]){
                vis[v]=1;
                if(linker[v]==-1 || DFS(linker[v])){
                    linker[v]=u;
                    return 1;
                }
            }
        return 0;
    }
    
    int Hungary(){
        int u,ans=0;
        memset(linker,-1,sizeof(linker));
        for(u=0;u<n;u++){
            memset(vis,0,sizeof(vis));
            if(DFS(u))
                ans++;
        }
        return ans;
    }
    
    int main(){
    
        //freopen("input.txt","r",stdin);
    
        while(~scanf("%d%d",&n,&k)){
            if(n==0 && k==0)
                break;
            st.clear();
            for(int i=0;i<n;i++)
                for(int j=0;j<n;j++){
                    scanf("%d",&num[i][j]);
                    st.insert(num[i][j]);
                }
            set<int>::iterator it;
            int x,cnt=0,tmp;
            for(it=st.begin();it!=st.end();it++){
                x=*it;
                for(int i=0;i<n;i++)
                    for(int j=0;j<n;j++)
                        map[i][j]=(x==num[i][j])?1:0;
                tmp=Hungary();
                if(k<tmp)
                    res[cnt++]=x;
            }
            if(cnt==0)
                printf("-1\n");
            else{
                for(int i=0;i<cnt;i++)
                    printf("%d%c",res[i],(i==cnt-1)?'\n':' ');
            }
        }
        return 0;
    }
  • 相关阅读:
    Setvlet基础(三) ServletContext
    Servlet基础(二) Servlet的生命周期
    Servlet基础(一) Servlet简介 关键API介绍及结合源码讲解
    JS执行队列
    this指向问题
    发送短信案例
    倒计时
    2:定时器
    1_2:调整窗口大小事件 [ onresize ]
    1_1:页面加载事件 [ window.onload ]
  • 原文地址:https://www.cnblogs.com/jackge/p/3014196.html
Copyright © 2011-2022 走看看