zoukankan      html  css  js  c++  java
  • HDU 1085 Holding BinLaden Captive! (母函数 | 多重背包)

    Holding Bin-Laden Captive!

    Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others) Total Submission(s): 11029    Accepted Submission(s): 4943

    Problem Description
    We all know that Bin-Laden is a notorious terrorist, and he has disappeared for a long time. But recently, it is reported that he hides in Hang Zhou of China!  “Oh, God! How terrible! ”
    Don’t be so afraid, guys. Although he hides in a cave of Hang Zhou, he dares not to go out. Laden is so bored recent years that he fling himself into some math problems, and he said that if anyone can solve his problem, he will give himself up!  Ha-ha! Obviously, Laden is too proud of his intelligence! But, what is his problem? “Given some Chinese Coins (硬币) (three kinds-- 1, 2, 5), and their number is num_1, num_2 and num_5 respectively, please output the minimum value that you cannot pay with given coins.” You, super ACMer, should solve the problem easily, and don’t forget to take $25000000 from Bush!
     
    Input
    Input contains multiple test cases. Each test case contains 3 positive integers num_1, num_2 and num_5 (0<=num_i<=1000). A test case containing 0 0 0 terminates the input and this test case is not to be processed.
     
    Output
    Output the minimum positive value that one cannot pay with given coins, one line for one case.
     
    Sample Input
    1 1 3
    0 0 0
     
    Sample Output
    4
     
    Author
    lcy
     
     
     1,母函数:
    #include<iostream>
    #include<cstdio>
    #include<cstring>
    
    using namespace std;
    
    const int N=8010;
    
    int num[4],money[4]={0,1,2,5};
    int c1[N],c2[N];
    
    int main(){
    
        //freopen("input.txt","r",stdin);
    
        while(~scanf("%d%d%d",&num[1],&num[2],&num[3])){
            if(num[1]==0 && num[2]==0 && num[3]==0)
                break;
            for(int i=0;i<N;i++){
                c1[i]=0;
                c2[i]=0;
            }
            c1[0]=1;
            int maxx=0;
            for(int i=1;i<=3;i++){
                maxx+=num[i]*money[i];
                for(int j=0;j<=maxx;j++)
                    for(int k=0;k<=num[i] && j+k*money[i]<=maxx;k++)
                        c2[j+k*money[i]]+=c1[j];
                for(int j=0;j<=maxx;j++){
                    c1[j]=c2[j];
                    c2[j]=0;
                }
            }
            for(int i=1;;i++)
                if(c1[i]==0){
                    printf("%d\n",i);
                    break;
                }
        }
        return 0;
    }

    2,多重背包:

    #include<iostream>
    #include<cstdio>
    #include<cstring>
    
    using namespace std;
    
    int num[3],money[3]={1,2,5};
    int dp[8010];
    
    int main(){
    
        //freopen("input.txt","r",stdin);
    
        while(~scanf("%d%d%d",&num[0],&num[1],&num[2])){
            if(num[0]==0 && num[1]==0 && num[2]==0)
                break;
            memset(dp,0,sizeof(dp));
            int tot=num[0]*1+num[1]*2+num[2]*5;
            dp[0]=1;
            for(int i=0;i<3;i++)    //简单的多重背包
                for(int j=0;j<num[i];j++)
                    for(int k=tot;k>=money[i];k--)
                        dp[k]+=dp[k-money[i]];
            int ans=tot+1;
            for(int i=1;i<=tot;i++)
                if(dp[i]==0){
                    ans=i;
                    break;
                }
            printf("%d\n",ans);
        }
        return 0;
    }
  • 相关阅读:
    MySql入门知识(一)
    一起学Android之Handler
    一起学Android之Http访问
    一起学Android之Sqlite
    一起学Android之Storage
    iOS核心动画高级技巧-1
    iOS界面流畅技巧之微博 Demo 性能优化技巧
    IOS 企业版证书($299)In-House方式发布指南
    App Store生存指南
    企业证书发布APP
  • 原文地址:https://www.cnblogs.com/jackge/p/3028163.html
Copyright © 2011-2022 走看看