zoukankan      html  css  js  c++  java
  • HDU 1398 Square Coins (母函数 | 完全背包)

    Square Coins

    Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others) Total Submission(s): 6093    Accepted Submission(s): 4111

    Problem Description
    People in Silverland use square coins. Not only they have square shapes but also their values are square numbers. Coins with values of all square numbers up to 289 (=17^2), i.e., 1-credit coins, 4-credit coins, 9-credit coins, ..., and 289-credit coins, are available in Silverland.  There are four combinations of coins to pay ten credits: 
    ten 1-credit coins, one 4-credit coin and six 1-credit coins, two 4-credit coins and two 1-credit coins, and one 9-credit coin and one 1-credit coin. 
    Your mission is to count the number of ways to pay a given amount using coins of Silverland.
     
    Input
    The input consists of lines each containing an integer meaning an amount to be paid, followed by a line containing a zero. You may assume that all the amounts are positive and less than 300.
     
    Output
    For each of the given amount, one line containing a single integer representing the number of combinations of coins should be output. No other characters should appear in the output. 
     
    Sample Input
    2
    10
    30
    0
     
    Sample Output
    1
    4
    27
     
    Source
     
    Recommend
    Ignatius.L
     
     
     1,母函数:
    #include<iostream>
    #include<cstdio>
    #include<cstring>
    
    using namespace std;
    
    const int N=320;
    
    int money[]={0,1,4,9,16,25,36,49,64,81,100,121,144,169,196,225,256,289};
    int c1[N],c2[N];
    
    int main(){
    
        //freopen("input.txt","r",stdin);
    
        int n;
        while(~scanf("%d",&n) && n){
            for(int i=0;i<=n;i++){
                c1[i]=0;
                c2[i]=0;
            }
            c1[0]=1;
            for(int i=1;i<=17;i++){
                for(int j=0;j<=n;j++)
                    for(int k=0;j+k*money[i]<=n;k++)
                        c2[j+k*money[i]]+=c1[j];
                for(int j=0;j<=n;j++){
                    c1[j]=c2[j];
                    c2[j]=0;
                }
            }
            printf("%d\n",c1[n]);
        }
        return 0;
    }

    2,完全背包:

    #include<iostream>
    #include<cstdio>
    #include<cstring>
    
    using namespace std;
    
    int money[]={1,4,9,16,25,36,49,64,81,100,121,144,169,196,225,256,289};
    int dp[320];
    
    int main(){
    
        //freopen("input.txt","r",stdin);
    
        int n;
        while(~scanf("%d",&n) && n){
            memset(dp,0,sizeof(dp));
            dp[0]=1;
            for(int i=0;i<17;i++)
                for(int j=money[i];j<=n;j++)
                    dp[j]+=dp[j-money[i]];
            printf("%d\n",dp[n]);
        }
        return 0;
    }
  • 相关阅读:
    读书-《智能时代》-机器智能正在革我们的命
    判断Http服务器是否支持支持断点续传
    最全Html标签Meta介绍
    用PHP整理照片和视频文件
    读书-《癌症.真相:医生也在读》-我所认识的癌症
    scrapy-redis组件配置用例
    Scrapy+seleninu抓取内容同时下载图片几个问题
    无界浏览器Chorme命令行开关
    Scrapy Crawl 运行出错 AttributeError: 'xxxSpider' object has no attribute '_rules' 的问题解决
    福利,OpenCV最新中文版官方教程来了
  • 原文地址:https://www.cnblogs.com/jackge/p/3028177.html
Copyright © 2011-2022 走看看