zoukankan      html  css  js  c++  java
  • HDU 1171 Big Event in HDU (母函数 | 背包 )

    Big Event in HDU

    Time Limit: 10000/5000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others) Total Submission(s): 16262    Accepted Submission(s): 5741

    Problem Description
    Nowadays, we all know that Computer College is the biggest department in HDU. But, maybe you don't know that Computer College had ever been split into Computer College and Software College in 2002. The splitting is absolutely a big event in HDU! At the same time, it is a trouble thing too. All facilities must go halves. First, all facilities are assessed, and two facilities are thought to be same if they have the same value. It is assumed that there is N (0<N<1000) kinds of facilities (different value, different kinds).
     
    Input
    Input contains multiple test cases. Each test case starts with a number N (0 < N <= 50 -- the total number of different facilities). The next N lines contain an integer V (0<V<=50 --value of facility) and an integer M (0<M<=100 --corresponding number of the facilities) each. You can assume that all V are different. A test case starting with a negative integer terminates input and this test case is not to be processed.
     
    Output
    For each case, print one line containing two integers A and B which denote the value of Computer College and Software College will get respectively. A and B should be as equal as possible. At the same time, you should guarantee that A is not less than B.
     
    Sample Input
    2
    10 1
    20 1
    3
    10 1
    20 2
    30 1
    -1
     
    Sample Output
    20 10
    40 40
     
    Author
    lcy
     
     
     1,母函数:
     
    #include<iostream>
    #include<cstdio>
    #include<cstring>
    
    using namespace std;
    
    const int N=250010;
    
    int n,val[60],amount[60];
    int c1[N],c2[N];
    
    int main(){
    
        //freopen("input.txt","r",stdin);
    
        while(~scanf("%d",&n) && n>0){      //天杀的n>0,我写成 n!=-1 WA了N久
            int tot=0;
            for(int i=0;i<N;i++){
                c1[i]=0;
                c2[i]=0;
            }
            for(int i=1;i<=n;i++){
                scanf("%d%d",&val[i],&amount[i]);
                tot+=val[i]*amount[i];
            }
            c1[0]=1;
            int maxx=0;
            for(int i=1;i<=n;i++){
                maxx+=val[i]*amount[i];
                for(int j=0;j<=maxx;j++)
                    for(int k=0;k<=amount[i] && j+k*val[i]<=maxx;k++)
                        c2[j+k*val[i]]+=c1[j];
                for(int j=0;j<=maxx;j++){
                    c1[j]=c2[j];
                    c2[j]=0;
                }
            }
            for(int i=tot/2;i>=0;i--)
                if(c1[i]!=0){
                    printf("%d %d\n",tot-i,i);
                    break;
                }
        }
        return 0;
    }

    2,背包:

    #include<iostream>
    #include<cstdio>
    #include<cstring>
    
    using namespace std;
    
    const int N=250010;
    
    int n,val[60],amount[60];
    int dp[N];
    
    int main(){
    
        //freopen("input.txt","r",stdin);
    
        while(~scanf("%d",&n) && n>0){      //天杀的n>0,我写成 n!=-1 WA了N久
            int tot=0;
            for(int i=0;i<n;i++){
                scanf("%d%d",&val[i],&amount[i]);
                tot+=val[i]*amount[i];
            }
            memset(dp,0,sizeof(dp));
            dp[0]=1;
            for(int i=0;i<n;i++)
                for(int j=0;j<amount[i];j++)
                    for(int k=tot/2;k>=val[i];k--)
                        dp[k]+=dp[k-val[i]];
            int i;
            for(i=tot/2;i>=0;i--)
                if(dp[i]!=0){
                    printf("%d %d\n",tot-i,i);
                    break;
                }
            if(i==-1){  //如果到最后还不能分,则输出以下结果
                printf("%d %d\n",tot,0);
            }
        }
        return 0;
    }
    #include<iostream>
    #include<cstdio>
    #include<cstring>
    
    using namespace std;
    
    const int N=256010;
    
    int n,val[60],amount[60];
    int dp[N];
    
    int main(){
    
        //freopen("input.txt","r",stdin);
    
        while(~scanf("%d",&n) && n>0){
            int tot=0;
            for(int i=0;i<n;i++){
                scanf("%d%d",&val[i],&amount[i]);
                tot+=val[i]*amount[i];
            }
            memset(dp,0,sizeof(dp));
            for(int i=0;i<n;i++)
                for(int j=0;j<amount[i];j++)
                    for(int k=tot/2;k>=val[i];k--)
                        dp[k]=max(dp[k],dp[k-val[i]]+val[i]);
            printf("%d %d\n",tot-dp[tot/2],dp[tot/2]);
        }
        return 0;
    }
  • 相关阅读:
    如何在 Creator3D 中切换模型贴图,超级简单!
    研究了3天,终于将 Shader 移植到 Cocos Creator 2.2.0 上了!
    Creator3D 守护你的球球—UV动画与天空盒
    一个玩游戏的失足青年,转行做软件开发的挣扎过程
    Cocos Creator 3D 打砖块教程(二) | 子弹发射与摄像机平滑移动
    Cocos Creator 3D 打砖块图文教程(一)
    Creator3D长什么样?看看官方惊艳的DEMO就知道了,附在线体验!
    不要总想着二进制
    关于 JSX
    早教
  • 原文地址:https://www.cnblogs.com/jackge/p/3028207.html
Copyright © 2011-2022 走看看