zoukankan      html  css  js  c++  java
  • HDU Best Reward (扩展KMP)

    Best Reward

    Time Limit : 2000/1000ms (Java/Other)   Memory Limit : 65536/65536K (Java/Other)
    Total Submission(s) : 23   Accepted Submission(s) : 8
    Problem Description
    After an uphill battle, General Li won a great victory. Now the head of state decide to reward him with honor and treasures for his great exploit. 

    One of these treasures is a necklace made up of 26 different kinds of gemstones, and the length of the necklace is n. (That is to say: n gemstones are stringed together to constitute this necklace, and each of these gemstones belongs to only one of the 26 kinds.) 

    In accordance with the classical view, a necklace is valuable if and only if it is a palindrome - the necklace looks the same in either direction. However, the necklace we mentioned above may not a palindrome at the beginning. So the head of state decide to cut the necklace into two part, and then give both of them to General Li. 

    All gemstones of the same kind has the same value (may be positive or negative because of their quality - some kinds are beautiful while some others may looks just like normal stones). A necklace that is palindrom has value equal to the sum of its gemstones' value. while a necklace that is not palindrom has value zero. 

    Now the problem is: how to cut the given necklace so that the sum of the two necklaces's value is greatest. Output this value. 

     
    Input
    The first line of input is a single integer T (1 ≤ T ≤ 10) - the number of test cases. The description of these test cases follows. 

    For each test case, the first line is 26 integers: v1, v2, ..., v26 (-100 ≤ vi ≤ 100, 1 ≤ i ≤ 26), represent the value of gemstones of each kind. 

    The second line of each test case is a string made up of charactor 'a' to 'z'. representing the necklace. Different charactor representing different kinds of gemstones, and the value of 'a' is v1, the value of 'b' is v2, ..., and so on. The length of the string is no more than 500000. 

     
    Output
    Output a single Integer: the maximum value General Li can get from the necklace.
     
    Sample Input
    2
    1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1
    aba
    1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1
    acacac

     
    Sample Output
    1
    6

     
    Source
    2010 ACM-ICPC Multi-University Training Contest(18)——Host by TJU
     
     
    #include<iostream>
    #include<cstdio>
    #include<cstring>
    
    using namespace std;
    
    const int maxn=500010;
    const int INF=0x3f3f3f3f;
    
    char s[maxn],t[maxn];
    int extend1[maxn],extend2[maxn],val[30],sum[maxn],next[maxn];
    
    void getnext(char *str,int *next){
        int len=strlen(str);
        int i=0;
        next[0]=len;
        while(i<len-1 && str[i]==str[i+1])
            i++;
        next[1]=i;
        i=1;
        for(int k=2;k<len;k++){
            int p=i+next[i]-1,L=next[k-i];
            if(k+L-1>=p){
                int j=max(p-k+1,0);
                while(k+j<len && str[k+j]==str[j])
                    j++;
                next[k]=j;
                i=k;
            }else
                next[k]=L;
        }
    }
    
    void EKMP(char *s,char *t,int *next,int *extend){
        getnext(t,next);
        int slen=strlen(s),tlen=strlen(t),i=0;
        int minlen=min(slen,tlen);
        while(i<minlen && s[i]==t[i])
            i++;
        extend[0]=i;
        i=0;
        for(int k=1;k<slen;k++){
            int p=i+extend[i]-1,L=next[k-i];
            if(k-1+L>=p){
                int j=max(p-k+1,0);
                while(k+j<slen && j<tlen && s[k+j]==t[j])
                    j++;
                extend[k]=j;
                i=k;
            }else
                extend[k]=L;
        }
    }
    
    int main(){
    
        //freopen("input.txt","r",stdin);
    
        int T;
        scanf("%d",&T);
        while(T--){
            for(int i=0;i<26;i++)
                scanf("%d",&val[i]);
            scanf("%s",s);
            memset(sum,0,sizeof(sum));
            int len=strlen(s);
            for(int i=0;s[i]!='\0';i++){
                sum[i+1]=sum[i]+val[s[i]-'a'];
                t[i]=s[len-1-i];
            }
            t[len]='\0';
            EKMP(s,t,next,extend2);
            EKMP(t,s,next,extend1);
            int max=-INF;
            for(int i=0;i<len;i++){
                if(i && extend1[i]+i==len){
                    int pos=extend1[i];
                    int tmp=sum[pos];
                    if(extend2[pos]+pos==len)
                        tmp+=sum[len]-sum[pos];
                    if(tmp>max)
                        max=tmp;
                }else{
                    int pos=i+1,tmp=0;
                    if(extend2[pos]+pos==len)
                        tmp+=sum[len]-sum[pos];
                    if(tmp>max)
                        max=tmp;
                }
            }
            printf("%d\n",max);
        }
        return 0;
    }
  • 相关阅读:
    bzoj 2784: [JLOI2012]时间流逝【树形期望dp】
    bzoj 3566: [SHOI2014]概率充电器【树形概率dp】
    bzoj 5277: [Usaco2018 Open]Out of Sorts【冒泡排序瞎搞】
    【04】在 PR 中关闭 issue
    【03】代码格式化+高亮
    【02】粘贴图像
    【01】在 Github 上编辑代码
    【02】GitHub 工具 Octotree
    【01】恶趣味玩转 GitHub commit 历史记录
    【07】Firebug监控网络情况
  • 原文地址:https://www.cnblogs.com/jackge/p/3040149.html
Copyright © 2011-2022 走看看