zoukankan      html  css  js  c++  java
  • HDU Cyclic Nacklace (KMP)

    Cyclic Nacklace

    Time Limit : 2000/1000ms (Java/Other)   Memory Limit : 32768/32768K (Java/Other)
    Total Submission(s) : 10   Accepted Submission(s) : 8
    Problem Description
    CC always becomes very depressed at the end of this month, he has checked his credit card yesterday, without any surprise, there are only 99.9 yuan left. he is too distressed and thinking about how to tide over the last days. Being inspired by the entrepreneurial spirit of "HDU CakeMan", he wants to sell some little things to make money. Of course, this is not an easy task.

    As Christmas is around the corner, Boys are busy in choosing christmas presents to send to their girlfriends. It is believed that chain bracelet is a good choice. However, Things are not always so simple, as is known to everyone, girl's fond of the colorful decoration to make bracelet appears vivid and lively, meanwhile they want to display their mature side as college students. after CC understands the girls demands, he intends to sell the chain bracelet called CharmBracelet. The CharmBracelet is made up with colorful pearls to show girls' lively, and the most important thing is that it must be connected by a cyclic chain which means the color of pearls are cyclic connected from the left to right. And the cyclic count must be more than one. If you connect the leftmost pearl and the rightmost pearl of such chain, you can make a CharmBracelet. Just like the pictrue below, this CharmBracelet's cycle is 9 and its cyclic count is 2:

    Now CC has brought in some ordinary bracelet chains, he wants to buy minimum number of pearls to make CharmBracelets so that he can save more money. but when remaking the bracelet, he can only add color pearls to the left end and right end of the chain, that is to say, adding to the middle is forbidden.
    CC is satisfied with his ideas and ask you for help.
     
    Input
    The first line of the input is a single integer T ( 0 < T <= 100 ) which means the number of test cases.
    Each test case contains only one line describe the original ordinary chain to be remade. Each character in the string stands for one pearl and there are 26 kinds of pearls being described by 'a' ~'z' characters. The length of the string Len: ( 3 <= Len <= 100000 ).
     
    Output
    For each case, you are required to output the minimum count of pearls added to make a CharmBracelet.
     
    Sample Input
    3
    aaa
    abca
    abcde
     
    Sample Output
    0
    2
    5
     
    Author
    possessor WC
     
    Source
    HDU 3rd “Vegetable-Birds Cup” Programming Open Contest
     
     

    该题旨在要求我们计算出达到两个循环节所补充的最少字符数,例如样例中的  "aaa"  已经满足达到两个循环,实质上已经有三个循环;"abca" 只需再补上 "ab" 两个字符即满足题意,而 "abcde" 则必须补上 5个字符才能满足题意了。

      这道题也是想了不少时间,原因在于我一直希望在求 next[] 数组时将其求解出来,当时的想法是假定母串无限长,超过原字符串长度就当做是任意字符进行处理,即无条件进行匹配,我觉得前面的思想还是不错的,但是后面的想法就有点天真了,由于是错误的答案就不在这里罗嗦了。

      后面发觉其实假设它为任意字符,不就是填充吗?找到循环节不就行了吗? 于是本题的关键就在寻找出循环节了,如何去找呢?这里还是要借助 next[] 的值,其实给定的一个串的循环节完全取决于最后一个字符后面假设字符的next[] 值(因为它反映了最后一个字符的匹配情况),为什么这么说呢,因为当我们考察最后一个字符的匹配情况时,我们就知道了最后这个字符能匹配够到该串的具体位置,而我们再用全串的长度减去这部分匹配的长度然后加上一,得到的就是循环节的长度了。

    详细解答:http://blog.csdn.net/niushuai666/article/details/6965517

    KMP算法详解:http://blog.csdn.net/niushuai666/article/details/6960985

    #include<iostream>
    #include<cstdio>
    #include<cstring>
    
    using namespace std;
    
    const int N=100010;
    
    char str[N];
    int len,next[N];
    
    void getnext(int len){
        int i=0,j=-1;
        next[0]=-1;
        while(i<len){
            if(j==-1 || str[i]==str[j]){
                i++;j++;
                next[i]=j;
            }else
                j=next[j];
        }
    }
    
    int main(){
    
        //freopen("input.txt","r",stdin);
    
        int t;
        scanf("%d",&t);
        while(t--){
            scanf("%s",str);
            len=strlen(str);
            getnext(len);
            int circle=len-next[len];    //循环节的长度
            if(len!=circle && len%circle==0)    //循环多次
                printf("0\n");
            else{
                int ans=circle-next[len]%circle;    //取余的作用:abcab,去掉abc
                printf("%d\n",ans);
            }
        }
        return 0;
    }
  • 相关阅读:
    install jprofiler for ubuntu
    android manifest相关属性
    install nginx for ubuntu
    Android shape
    mobile web for no cookie session
    Android布局属性
    什么是强类型,强类型集合
    radl (三) (转)
    几个.net 基础问题,自己回答了一些,请大家指教
    c#接口和抽象类的区别
  • 原文地址:https://www.cnblogs.com/jackge/p/3040319.html
Copyright © 2011-2022 走看看