zoukankan      html  css  js  c++  java
  • HDU 3549 Flow Problem (EK)

    Flow Problem

    Time Limit: 5000/5000 MS (Java/Others)    Memory Limit: 65535/32768 K (Java/Others)
    Total Submission(s): 4865    Accepted Submission(s): 2275


    Problem Description
    Network flow is a well-known difficult problem for ACMers. Given a graph, your task is to find out the maximum flow for the weighted directed graph.
     
    Input
    The first line of input contains an integer T, denoting the number of test cases.
    For each test case, the first line contains two integers N and M, denoting the number of vertexes and edges in the graph. (2 <= N <= 15, 0 <= M <= 1000)
    Next M lines, each line contains three integers X, Y and C, there is an edge from X to Y and the capacity of it is C. (1 <= X, Y <= N, 1 <= C <= 1000)
     
    Output
    For each test cases, you should output the maximum flow from source 1 to sink N.
     
    Sample Input
    2 3 2 1 2 1 2 3 1 3 3 1 2 1 2 3 1 1 3 1
     
    Sample Output
    Case 1: 1 Case 2: 2
     
    Author
    HyperHexagon
     
    Source
     
    Recommend
    zhengfeng
     
    #include<iostream>
    #include<cstdio>
    #include<cstring>
    
    using namespace std;
    
    const int VM=30;
    const int EM=1010;
    const int INF=0x3f3f3f3f;
    
    int map[VM][VM],q[VM],pre[VM],src,des;
    
    int BFS(int n){
        int front=0,rear=0;
        memset(pre,-1,sizeof(pre));
        pre[src]=0;
        q[rear++]=src;
        while(front!=rear){
            int u=q[front++];
            for(int v=1;v<=n;v++){
                if(pre[v]!=-1 || map[u][v]==0)
                    continue;
                pre[v]=u;
                if(v==des)
                    return 1;
                q[rear++]=v;
            }
        }
        return 0;
    }
    
    int EK(int n){
        int ans=0,i;
        while(BFS(n)){
            int tmp=INF;
            for(i=des;i!=src;i=pre[i])
                tmp=tmp<map[pre[i]][i]?tmp:map[pre[i]][i];
            ans+=tmp;
            for(i=des;i!=src;i=pre[i]){
                map[pre[i]][i]-=tmp;
                map[i][pre[i]]+=tmp;
            }
        }
        return ans;
    }
    
    int main(){
    
        //freopen("input.txt","r",stdin);
    
        int t,n,m;
        int cases=0;
        scanf("%d",&t);
        while(t--){
            scanf("%d%d",&n,&m);
            memset(map,0,sizeof(map));
            src=1;
            des=n;
            int u,v,w;
            while(m--){
                scanf("%d%d%d",&u,&v,&w);
                map[u][v]+=w;
            }
            int ans=EK(n);
            printf("Case %d: %d\n",++cases,ans);
        }
        return 0;
    }
  • 相关阅读:
    RedHat Linux-配置YUM仓库
    04、管道符、重定向与环境变量
    03、新手必须掌握的Linux命令
    size_t
    decltype关键字
    python numpy使用笔记
    Huffman编码
    动态规划(dynamic programming)
    Prim算法
    Kruskal算法
  • 原文地址:https://www.cnblogs.com/jackge/p/3061848.html
Copyright © 2011-2022 走看看