zoukankan      html  css  js  c++  java
  • POJ 3159 Candies

    Candies
    Time Limit: 1500MS   Memory Limit: 131072K
    Total Submissions: 19891   Accepted: 5241

    Description

    During the kindergarten days, flymouse was the monitor of his class. Occasionally the head-teacher brought the kids of flymouse’s class a large bag of candies and had flymouse distribute them. All the kids loved candies very much and often compared the numbers of candies they got with others. A kid A could had the idea that though it might be the case that another kid B was better than him in some aspect and therefore had a reason for deserving more candies than he did, he should never get a certain number of candies fewer than B did no matter how many candies he actually got, otherwise he would feel dissatisfied and go to the head-teacher to complain about flymouse’s biased distribution.

    snoopy shared class with flymouse at that time. flymouse always compared the number of his candies with that of snoopy’s. He wanted to make the difference between the numbers as large as possible while keeping every kid satisfied. Now he had just got another bag of candies from the head-teacher, what was the largest difference he could make out of it?

    Input

    The input contains a single test cases. The test cases starts with a line with two integers N and M not exceeding 30 000 and 150 000 respectively. N is the number of kids in the class and the kids were numbered 1 throughN. snoopy and flymouse were always numbered 1 and N. Then follow M lines each holding three integers AB and c in order, meaning that kid A believed that kid B should never get over c candies more than he did.

    Output

    Output one line with only the largest difference desired. The difference is guaranteed to be finite.

    Sample Input

    2 2
    1 2 5
    2 1 4

    Sample Output

    5

    Hint

    32-bit signed integer type is capable of doing all arithmetic.

    Source

     
     
     
    题意: 简单的说就是 给出m给 si 与sj的关系,其中sj的糖数不能比si的多c个,即sj-si <= c  最后求flymouse(n)最多能比soonpy(1) 多多少糖,

    思路:话说这是个差分约束问题 其实就是求最短路问题 只要求出dis[n]就行了 原先用 队列实现spfa 但超时了,因为是 每个点入队列超过30000 次 后改为栈实现 ps:有负环时,用栈比队列快,(原因是啥,我也不知道)
     
     
    栈实现:
    #include <stdio.h>
    #include <string.h>
    #define VM 30005
    #define EM 150005
    #define inf 0x3f
    int head[VM],ep;
    struct edge
    {
        int v,w,next;
    }e[EM];
    
    void addedge(int cu,int cv,int cw)
    {
        ep ++;
        e[ep].v = cv;
        e[ep].w = cw;
        e[ep].next = head[cu];
        head[cu] = ep;
    }
    
    void spfa (int n)
    {
        int vis[VM],stack[VM],dis[VM];
        memset (vis,0,sizeof(vis));
        memset (dis,0x3f,sizeof(dis));
        dis[1] = 0;
        vis[1] = 1;
        int top = 1;
        stack[0] = 1;
        while (top)
        {
            int u = stack[--top];
            vis[u] = 0;
            for (int i = head[u];i != -1;i = e[i].next)
            {
                int v = e[i].v;
                if (dis[v] > dis[u] + e[i].w)
                {
                    dis[v] = dis[u] + e[i].w;
                    if (!vis[v])
                    {
                        vis[v] = 1;
                        stack[top++] = v;
                    }
                }
            }
        }
    
        printf ("%d\n",dis[n]);
    }
    int main ()
    {
        int n,m,v1,v2,cost;
        ep = 0;
        memset (head,-1,sizeof(head));
        scanf ("%d%d",&n,&m);
        while (m--)
        {
            scanf ("%d%d%d",&v1,&v2,&cost);
            addedge (v1,v2,cost);
        }
        spfa (n);
        return 0;
    }
    
    
    队列实现:
    #include <stdio.h>
    #include <string.h>
    #define VM 300005
    #define EM 1500005
    #define inf 0x3f
    int head[VM],ep;
    struct edge
    {
        int v,w,next;
    }e[EM];
    
    void addedge(int cu,int cv,int cw)
    {
        ep ++;
        e[ep].v = cv;
        e[ep].w = cw;
        e[ep].next = head[cu];
        head[cu] = ep;
    }
    
    void spfa (int n)
    {
        int vis[VM],queue[VM],dis[VM];
        memset (vis,0,sizeof(vis));
        memset (dis,0x3f,sizeof(dis));
        dis[1] = 0;
        int front = -1,rear = 0;
        queue[rear++] = 1;
        vis[1] = 1;
        while (front != rear)
        {
            front = (front+1)%(n+1);
            int u = queue[front];
            vis[u] = 0;
            for (int i = head[u];i != -1;i = e[i].next)
            {
                if (dis[e[i].v] > dis[u]+e[i].w)
                   {
                       dis[e[i].v] = dis[u]+e[i].w;
                       if (!vis[e[i].v])
                       {
                           vis[e[i].v] = 1;
                           queue[rear] = e[i].v;
                           rear = (rear+1)%(n+1);
                       }
                   }
            }
        }
        printf ("%d\n",dis[n]);
    }
    int main ()
    {
        int n,m,v1,v2,cost;
        ep = 0;
        memset (head,-1,sizeof(head));
        scanf ("%d%d",&n,&m);
        while (m--)
        {
            scanf ("%d%d%d",&v1,&v2,&cost);
            addedge (v1,v2,cost);
        }
        spfa (n);
        return 0;
    }
  • 相关阅读:
    3813: 奇数国|树状数组|欧拉函数
    利用Perlin nosie 完毕(PS 滤镜—— 分成云彩)
    Qt QImageReader 相似乎有bug
    android studio 更新Gradle版本号方法
    Junit测试
    POI导出
    Properties文件读取
    md5加密
    递归找出文件夹里面所有文件
    java FileReader/FileWriter读写文件
  • 原文地址:https://www.cnblogs.com/jackge/p/3062026.html
Copyright © 2011-2022 走看看