zoukankan      html  css  js  c++  java
  • SDUT 2408 Pick apples

    Pick apples

    Time Limit: 1000ms   Memory limit: 165536K  有疑问?点这里^_^

    题目描述

    Once ago, there is a mystery yard which only produces three kinds of apples. The number of each kind is infinite. A girl carrying a big bag comes into the yard. She is so surprised because she has never seen so many apples before. Each kind of apple has a size and a price to be sold. Now the little girl wants to gain more profits, but she does not know how. So she asks you for help, and tell she the most profits she can gain.

    输入

    In the first line there is an integer T (T <= 50), indicates the number of test cases.
    In each case, there are four lines. In the first three lines, there are two integers S and P in each line, which indicates the size (1 <= S<= 100) and the price (1 <= P <= 10000) of this kind of apple.

    In the fourth line there is an integer V,(1 <= V <= 100,000,000)indicates the volume of the girl's bag.

    输出

    For each case, first output the case number then follow the most profits she can gain.

    示例输入

    1
    1 1
    2 1
    3 1
    6
    

    示例输出

    Case 1: 6

    提示

     

    来源

    2012年"浪潮杯"山东省第三届ACM大学生程序设计竞赛

    示例程序

    大范围贪心,小范围背包。。。。。。。。。。

    #include<iostream>
    #include<cstdio>
    #include<cstring>
    
    using namespace std;
    
    long long V,dp[2010],s[5],p[5];
    
    void CompletePack(long long ss,long long pp){
        for(long long i=ss;i<=V;i++)
            if(dp[i]<dp[i-ss]+pp)
                dp[i]=dp[i-ss]+pp;
    }
    
    int main(){
    
        //freopen("input.txt","r",stdin);
    
        int t,cases=0;
        scanf("%d",&t);
        while(t--){
            double val,max=0;
            int id;
            for(int i=0;i<3;i++){
                cin>>s[i]>>p[i];
                val=1.0*p[i]/s[i];
                if(max<val){
                    max=val;
                    id=i;
                }
            }
            cin>>V;
            memset(dp,0,sizeof(dp));
            cout<<"Case "<<++cases<<": ";
            if(V<=1000){    //小范围背包
                for(int i=0;i<3;i++)
                    CompletePack(s[i],p[i]);
                cout<<dp[V]<<endl;
            }else{  
                long long ans=(V-1000)/s[id]*p[id];     //大范围先贪心,后背包
                V=V-(V-1000)/s[id]*s[id];
                for(int i=0;i<3;i++)
                    CompletePack(s[i],p[i]);
                cout<<dp[V]+ans<<endl;
            }
        }
        return 0;
    }
  • 相关阅读:
    【存货管理】存货的计价方法
    【NHibernate】列“ReservedWord”不属于表 ReservedWords
    【MySQL】MySQL中where条件的执行分析
    brew卸载&重新安装
    mac nvm安装&使用&一些问题解决方案
    python初始环境配置
    股票数据api整理
    输入一个url到页面渲染完毕过程
    自己简单封装一个promise
    节流&防抖
  • 原文地址:https://www.cnblogs.com/jackge/p/3084149.html
Copyright © 2011-2022 走看看