zoukankan      html  css  js  c++  java
  • 1737 Play the Dice (期望 )

    1737 - Play the Dice

    http://icpc.njust.edu.cn/Local/1737

    时间限制: 2000 MS
    内存限制: 65535 MB

    问题描述

    There is a dice with N sides, which are numbered from 1,2,...,n and have the equal possibility to show up when one rolls a dice. Each side has an integer Ai on it. Now here is a game that you can roll this dice once, if the i-th side is up, you will get Ai yuan. What's more, some sids of this dice are colored with a special different color. If you turn this side up, you will get once more chance to roll the dice. When you roll the dice for the second time, you still have the opportunity to win money and rolling chance. Now you need to calculate the expectations of money that we get after playing the game once.

    输入说明

    Input consists of multiple cases. Each case includes two lines. End with EOF.
    The first line is an integer N (2<=N<=200), following with N integers Ai(0<=Ai<200)
    The second line is an integer M (0<=M<=N), following with m integers Bi(1<=Bi<=n), which are the numbers of the special sides to get another more chance.

    输出说明

    Just a real number which is the expectations of the money one can get, rounded to exact two digits. If you can get unlimited money, print "inf" a line without double quotes.

    输入样例

    6 1 2 3 4 5 6
    0
    4 0 0 0 0
    1 3
    

    输出样例

    3.50
    0.00
    

    来源

    2013 ACM-ICPC China Nanjing Invitational Programming Contest
     
     

    ans=M/N *ans+1/N*(A[1]+A[2]+A[3]+....+A[N]);

    (N-M)ans= A[1]+A[2]+...+A[N]=sum;

    如果sum==0,答案为0.00

    如果sum!=0,N-M==0  答案为inf

    否则答案就是sum/(N-M);

    #include<iostream>
    #include<cstdio>
    #include<cstring>
    
    using namespace std;
    
    const int N=220;
    
    int a[N],b[N];
    int n,m;
    
    int main(){
    
        //freopen("input.txt","r",stdin);
    
        while(~scanf("%d",&n)){
            int sum=0;
            for(int i=0;i<n;i++){
                scanf("%d",&a[i]);
                sum+=a[i];
            }
            //printf("sum=%d\n",sum);
            scanf("%d",&m);
            for(int i=0;i<m;i++)
                scanf("%d",&b[i]);
            if(sum==0){
                printf("0.00\n");
                continue;
            }
            if(n==m){
                printf("inf\n");
                continue;
            }
            printf("%.2lf\n",1.0*sum/(n-m));
        }
        return 0;
    }
  • 相关阅读:
    js判断是否为数字
    MongoDB 复制集机制及原理
    MongoDB 聚合查询
    C#中时间相关知识点小结
    C#中的小数和百分数计算
    WPF使用VisualTreeHelper进行复杂命中测试
    WPF使用VisualTreeHelperj简单进行命中测试
    WPF Data Binding数据驱动
    WPF Binding中的RelativeSource属性
    WPF特效:流光动画效果
  • 原文地址:https://www.cnblogs.com/jackge/p/3086571.html
Copyright © 2011-2022 走看看