zoukankan      html  css  js  c++  java
  • POJ 3744 Scout YYF I (概率DP & 期望 + 矩阵乘法)

    Scout YYF I
    Time Limit: 1000MS   Memory Limit: 65536K
    Total Submissions: 3871   Accepted: 975

    Description

    YYF is a couragous scout. Now he is on a dangerous mission which is to penetrate into the enemy's base. After overcoming a series difficulties, YYF is now at the start of enemy's famous "mine road". This is a very long road, on which there are numbers of mines. At first, YYF is at step one. For each step after that, YYF will walk one step with a probability of p, or jump two step with a probality of 1-p. Here is the task, given the place of each mine, please calculate the probality that YYF can go through the "mine road" safely.

    Input

    The input contains many test cases ended with EOF.
    Each test case contains two lines.
    The First line of each test case is N (1 ≤ N ≤ 10) and p (0.25 ≤ p ≤ 0.75) seperated by a single blank, standing for the number of mines and the probability to walk one step.
    The Second line of each test case is N integer standing for the place of N mines. Each integer is in the range of [1, 100000000].

    Output

    For each test case, output the probabilty in a single line with the precision to 7 digits after the decimal point.

    Sample Input

    1 0.5
    2
    2 0.5
    2 4

    Sample Output

    0.5000000
    0.2500000

    Source

     
    题意:在一条不满地雷的路上,你现在的起点在1处。在N个点处布有地雷,1<=N<=10。地雷点的坐标范围:[1,100000000].
    每次前进p的概率前进一步,1-p的概率前进1-p步。问顺利通过这条路的概率。就是不要走到有地雷的地方。
     
    设dp[i]表示到达i点的概率,则 初始值 dp[1]=1.
    很容易想到转移方程: dp[i]=p*dp[i-1]+(1-p)*dp[i-2];
    但是由于坐标的范围很大,直接这样求是不行的,而且当中的某些点还存在地雷。
     
    N个有地雷的点的坐标为 x[1],x[2],x[3]```````x[N].
    我们把道路分成N段:
    1~x[1];
    x[1]+1~x[2];
    x[2]+1~x[3];
    `
    `
    `
    x[N-1]+1~x[N].
     
    这样每一段只有一个地雷。我们只要求得通过每一段的概率。乘法原理相乘就是答案。
    对于每一段,通过该段的概率等于1-踩到该段终点的地雷的概率。
     
    就比如第一段 1~x[1].  通过该段其实就相当于是到达x[1]+1点。那么p[x[1]+1]=1-p[x[1]].
    但是这个前提是p[1]=1,即起点的概率等于1.对于后面的段我们也是一样的假设,这样就乘起来就是答案了。
     
    对于每一段的概率的求法可以通过矩阵乘法快速求出来。
     

    显然,如果k 号位有雷,那么安全通过这个雷只可能是在 k-1 号位选择走两步到 k+1 号位。因此,可以得到如下结论:在第 i 个雷的被处理掉的概率就是从 a[i-1]+1 号位到 a[i] 号位的概率。于是,可以用 1 减去就可以求出安全通过第 i 个雷的概率,最后乘起来即可,比较悲剧的是数据很大,所以需要用到矩阵快速幂……

    类似斐波那契数列,有ans[i]=p*ans[i-1]+(1-p)*ans[i-2] ,构造矩阵为

     

    #include<iostream>
    #include<cstdio>
    #include<cstring>
    #include<algorithm>
    
    using namespace std;
    
    struct Matrix{
        double m[2][2];
    };
    
    Matrix init,unit;
    int n,num[20];
    double p;
    
    Matrix Mul(Matrix a,Matrix b){
        Matrix c;
        for(int i=0;i<2;i++)
            for(int j=0;j<2;j++){
                c.m[i][j]=0;
                for(int k=0;k<2;k++)
                    c.m[i][j]+=a.m[i][k]*b.m[k][j];
            }
        return c;
    }
    
    Matrix Pow(Matrix a,Matrix b,int k){
        while(k){
            if(k&1){
                b=Mul(a,b);
            }
            a=Mul(a,a);
            k>>=1;
        }
        return b;
    }
    
    void Init(){
        init.m[0][0]=p;
        init.m[0][1]=1-p;
        init.m[1][0]=1;
        init.m[1][1]=0;
        memset(unit.m,0,sizeof(unit.m));
        for(int i=0;i<2;i++)
            unit.m[i][i]=1;
    }
    
    int main(){
    
        //freopen("input.txt","r",stdin);
    
        while(~scanf("%d%lf",&n,&p)){
            for(int i=0;i<n;i++)
                scanf("%d",&num[i]);
            sort(num,num+n);
            Init();
            Matrix res=Pow(init,unit,num[0]-1);
            double ans=1-res.m[0][0];
            for(int i=1;i<n;i++){
                if(num[i-1]==num[i])
                    continue;
                res=Pow(init,unit,num[i]-(num[i-1]+1));
                ans*=(1-res.m[0][0]);
            }
            printf("%.7f\n",ans);
        }
        return 0;
    }

     

  • 相关阅读:
    自定义异常
    this()和super()的区别
    Eclipse快速创建函数
    Eclipse的.java文件有蓝色三角符号
    可变数量参数
    近期的目标
    怎么在电脑右键的新建里面添加.md文件
    数组的排序(从小到大)
    Arrays类
    不用乘法计算乘法(快速计算)
  • 原文地址:https://www.cnblogs.com/jackge/p/3091720.html
Copyright © 2011-2022 走看看