zoukankan      html  css  js  c++  java
  • ZOJ 3329 One Person Game (概率DP & 期望)

    One Person Game

    Time Limit: 1 Second      Memory Limit: 32768 KB      Special Judge

    There is a very simple and interesting one-person game. You have 3 dice, namely Die1Die2 and Die3Die1 has K1 faces. Die2 has K2 faces. Die3 has K3 faces. All the dice are fair dice, so the probability of rolling each value, 1 to K1K2K3 is exactly 1 / K1, 1 / K2 and 1 / K3. You have a counter, and the game is played as follow:

    1. Set the counter to 0 at first.
    2. Roll the 3 dice simultaneously. If the up-facing number of Die1 is a, the up-facing number of Die2 is b and the up-facing number of Die3 is c, set the counter to 0. Otherwise, add the counter by the total value of the 3 up-facing numbers.
    3. If the counter's number is still not greater than n, go to step 2. Otherwise the game is ended.

    Calculate the expectation of the number of times that you cast dice before the end of the game.

    Input

    There are multiple test cases. The first line of input is an integer T (0 < T <= 300) indicating the number of test cases. Then T test cases follow. Each test case is a line contains 7 non-negative integers nK1K2K3abc (0 <= n <= 500, 1 < K1K2K3 <= 6, 1 <= a <= K1, 1 <= b <= K2, 1 <= c <= K3).

    Output

    For each test case, output the answer in a single line. A relative error of 1e-8 will be accepted.

    Sample Input

    2
    0 2 2 2 1 1 1
    0 6 6 6 1 1 1
    

    Sample Output

    1.142857142857143
    1.004651162790698
    
    1. /** 
    2.     dp求期望的题。 
    3.     题意: 
    4.     有三个均匀的骰子,分别有k1,k2,k3个面,初始分数是0, 
    5.     当掷三个骰子的点数分别为a,b,c的时候,分数清零,否则分数加上三个骰子的点数和, 
    6.     当分数>n的时候结束。求需要掷骰子的次数的期望。 
    7.     题解: 
    8.     设 E[i]表示现在分数为i,到结束游戏所要掷骰子的次数的期望值。 
    9.     显然 E[>n] = 0; E[0]即为所求答案; 
    10.     E[i] = ∑Pk*E[i+k] + P0*E[0] + 1; (Pk表示点数和为k的概率,P0表示分数清零的概率) 
    11.     由上式发现每个 E[i]都包含 E[0],而 E[0]又是我们要求的,是个定值。 
    12.     设 E[i] = a[i]*E[0] + b[i]; 
    13.     将其带入上面的式子: 
    14.     E[i] = ( ∑Pk*a[i+k] + P0 )*E[0] + ∑Pk*b[i+k] + 1; 
    15.     显然, 
    16.     a[i] = ∑Pk*a[i+k] + P0; 
    17.     b[i] = ∑Pk*b[i+k] + 1; 
    18.     当 i > n 时: 
    19.     E[i] = a[i]*E[0] + b[i] = 0; 
    20.     所以 a[i>n] = b[i>n] = 0; 
    21.     可依次算出 a[n],b[n]; a[n-1],b[n-1] ... a[0],b[0]; 
    22.     则 E[0] = b[0]/(1 - a[0]); 
    23. **/
    #include<iostream>
    #include<cstdio>
    #include<cstring>
    
    using namespace std;
    
    int main(){
    
        //freopen("input.txt","r",stdin);
    
        int t,n,k1,k2,k3,a,b,c;
        scanf("%d",&t);
        double p0,p[20];
        while(t--){
            cin>>n>>k1>>k2>>k3>>a>>b>>c;
            int tot=k1+k2+k3;
            p0=1.0/(k1*k2*k3);
            memset(p,0,sizeof(p));
            for(int i=1;i<=k1;i++)
                for(int j=1;j<=k2;j++)
                    for(int k=1;k<=k3;k++)
                        if(i!=a || j!=b || k!=c)
                            p[i+j+k]+=p0;
            double a[520]={0},b[520]={0};
            for(int i=n;i>=0;i--){
                for(int k=3;k<=tot;k++){
                    a[i]+=a[i+k]*p[k];
                    b[i]+=b[i+k]*p[k];
                }
                a[i]+=p0;
                b[i]+=1;
            }
            printf("%.15lf\n",b[0]/(1-a[0]));
        }
        return 0;
    }
  • 相关阅读:
    调整swt table的行高
    获取TableViewer里面的所有TableViewerColumn
    jface viewer 全选
    jaxb生成pojo类返回类型为布尔值的问题
    EMF中复制对象属性
    向导中的参数传递 wizard param
    GEF中TreeViewer的叶子节点展开
    Cannot modify resource set without a write transaction 问题
    注册emf package并读取EMF文件
    从运行时的工作空间获取EMF文件(IFILE)
  • 原文地址:https://www.cnblogs.com/jackge/p/3091839.html
Copyright © 2011-2022 走看看