zoukankan      html  css  js  c++  java
  • ZOJ 3471 Most Powerful (状压DP)

    Most Powerful

    Time Limit: 2 Seconds      Memory Limit: 65536 KB

    Recently, researchers on Mars have discovered N powerful atoms. All of them are different. These atoms have some properties. When two of these atoms collide, one of them disappears and a lot of power is produced. Researchers know the way every two atoms perform when collided and the power every two atoms can produce.

    You are to write a program to make it most powerful, which means that the sum of power produced during all the collides is maximal.

    Input

    There are multiple cases. The first line of each case has an integer N (2 <= N <= 10), which means there are N atoms: A1, A2, ... , AN. Then N lines follow. There are N integers in each line. The j-th integer on the i-th line is the power produced when Ai and Aj collide with Aj gone. All integers are positive and not larger than 10000.

    The last case is followed by a 0 in one line.

    There will be no more than 500 cases including no more than 50 large cases that N is 10.

    Output

    Output the maximal power these N atoms can produce in a line for each case.

    Sample Input

    2
    0 4
    1 0
    3
    0 20 1
    12 0 1
    1 10 0
    0

    Sample Output

    4
    22


    Author: GAO, Yuan
    Contest: ZOJ Monthly, February 2011

    题目的意思是研究人员发现有N个原子两两组合会发生反应产生能量,且其中一个会被和谐掉,给出一个矩阵map,其中map[i][j]表示原子i与j发生反应且原子j被和谐掉所释放的能量,问给定的n个原子反应最多能产生多少能量。

    显然直接枚举是不可行的,因为复杂度是O(n!),虽然10!在10^7左右,但是有50个测试数据的n=10,所以估计会超时的。

    假设一个数,第i位表示第i个原子是否被灭掉,如果被灭掉则为1,没被灭掉为0,那么所有状态都可以用2^n范围内的数来表示。假设对于其中一个数(n=4)

    1 0 1 0,(也就是十进制的10)则表示第二个原子和第四个原子都被灭掉,而第一、三个原子幸存,那么,假设知道这个状态下释放能量的最大值,那么我们可以拓展出1 1 1 0 和1 0 1 1 这两个状态通过1 0 1 0达到的值,那么对于每个状态进行这种拓展,那么就可以求出每个状态下释放能量的最大值,所以最后的最大值就求出来了。

    #include<iostream>
    #include<cstdio>
    #include<cstring>
    
    using namespace std;
    
    int n,map[15][15];
    int dp[1200];
    
    int main(){
    
        //freopen("input.txt","r",stdin);
    
        while(~scanf("%d",&n) && n){
            for(int i=0;i<n;i++)
                for(int j=0;j<n;j++)
                    scanf("%d",&map[i][j]);
            for(int i=0;i<(1<<n);i++)
                dp[i]=0;
            for(int i=0;i<(1<<n);i++)   //对于每个状态进行拓展
                for(int j=0;j<n;j++){   //枚举每一位,也就是说枚举每个原子将其和谐掉 
                    if((i&(1<<j))!=0)   //如果在状态i下该原子已经被和谐了,那么跳过看下一个原子  
                        continue;
                    for(int k=0;k<n;k++)    //否则找一个没有被和谐的原子和谐掉原子
                        if((i&(1<<k))==0 && j!=k)
                            dp[i|(1<<j)]=max(dp[i|(1<<j)],dp[i]+map[k][j]);
                }
            int ans=0;
            for(int i=0;i<(1<<n);i++)
                if(ans<dp[i])
                    ans=dp[i];
            printf("%d\n",ans);
        }
        return 0;
    }
  • 相关阅读:
    TCP性能调优
    Qt 实现应用程序单实例运行
    table多选
    多选删除最佳处理
    获取路由或路径
    当前页面打开新页面
    vue版本更新index.html缓存
    vue项目js和css文件名避免浏览器缓存再vue.config.js中配置
    vue动态表格
    IE网页被缓存,get接口缓存
  • 原文地址:https://www.cnblogs.com/jackge/p/3096637.html
Copyright © 2011-2022 走看看