zoukankan      html  css  js  c++  java
  • HDU 4642 Fliping game (简单博弈)

    Fliping game

    Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
    Total Submission(s): 307    Accepted Submission(s): 220


    Problem Description
    Alice and Bob are playing a kind of special game on an N*M board (N rows, M columns). At the beginning, there are N*M coins in this board with one in each grid and every coin may be upward or downward freely. Then they take turns to choose a rectangle (x1, y1)-(n, m) (1 ≤ x1≤n, 1≤y1≤m) and flips all the coins (upward to downward, downward to upward) in it (i.e. flip all positions (x, y) where x1≤x≤n, y1≤y≤m)). The only restriction is that the top-left corner (i.e. (x1, y1)) must be changing from upward to downward. The game ends when all coins are downward, and the one who cannot play in his (her) turns loses the game. Here's the problem: Who will win the game if both use the best strategy? You can assume that Alice always goes first.
     
    Input
    The first line of the date is an integer T, which is the number of the text cases.
    Then T cases follow, each case starts with two integers N and M indicate the size of the board. Then goes N line, each line with M integers shows the state of each coin, 1<=N,M<=100. 0 means that this coin is downward in the initial, 1 means that this coin is upward in the initial.
     
    Output
    For each case, output the winner’s name, either Alice or Bob.
     
    Sample Input
    2 2 2 1 1 1 1 3 3 0 0 0 0 0 0 0 0 0
     
    Sample Output
    Alice Bob
     
    Source
     
    Recommend
    zhuyuanchen520
     

     签到题,可是却没仔细理解题意,导致没签到成功,这是病,得治。

    思路:
    最后一个格子是会被任意格子影响的。
    每次只要保证自己取完后, 最后一个格子是0, 就不会输。
    因为: 对于后者如果还能取,最后一个格子肯定会变成1,  那么自己就还能取。 如果后者已经没得取了, 那么自己就已经赢了。
     
    #include<iostream>
    #include<cstdio>
    #include<cstring>
    #include<algorithm>
    
    using namespace std;
    
    int n,m;
    
    int main(){
    
        //freopen("input.txt","r",stdin);
    
        int t;
        scanf("%d",&t);
        while(t--){
            scanf("%d%d",&n,&m);
            int x;
            for(int i=0;i<n;i++)
                for(int j=0;j<m;j++)
                    scanf("%d",&x);
            if(x)
                puts("Alice");
            else
                puts("Bob");
        }
        return 0;
    }
  • 相关阅读:
    js数组操作
    docker操作命令
    swoole使用案例
    swoole实现视频弹幕效果
    swoole的UDP服务
    swoole的TCP服务
    安装回环网卡&安装Linux前准备
    Linux之安装Linux详细步骤
    Spring Boot的面试题
    Shell 脚本面试问题大全
  • 原文地址:https://www.cnblogs.com/jackge/p/3231573.html
Copyright © 2011-2022 走看看