zoukankan      html  css  js  c++  java
  • HDU 3951 Coin Game (简单博弈)

    Coin Game

    Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
    Total Submission(s): 888    Accepted Submission(s): 547


    Problem Description
    After hh has learned how to play Nim game, he begins to try another coin game which seems much easier.

    The game goes like this: 
    Two players start the game with a circle of n coins. 
    They take coins from the circle in turn and every time they could take 1~K continuous coins. 
    (imagining that ten coins numbered from 1 to 10 and K equal to 3, since 1 and 10 are continuous, you could take away the continuous 10 , 1 , 2 , but if 2 was taken away, you couldn't take 1, 3, 4, because 1 and 3 aren't continuous)
    The player who takes the last coin wins the game. 
    Suppose that those two players always take the best moves and never make mistakes. 
    Your job is to find out who will definitely win the game.
     
    Input
    The first line is a number T(1<=T<=100), represents the number of case. The next T blocks follow each indicates a case.
    Each case contains two integers N(3<=N<=109,1<=K<=10).
     
    Output
    For each case, output the number of case and the winner "first" or "second".(as shown in the sample output)
     
    Sample Input
    2 3 1 3 2
     
    Sample Output
    Case 1: first Case 2: second
     
    Author
    NotOnlySuccess
     
    Source
     
    Recommend
    lcy

    题意:一圈n个的硬币, 两个玩家轮流取,每次他们可以取1 ~ K个连续硬币, 最后一个取完为胜;

    思路: 面对一个可以一次拿完的局面先手必胜, 如果k=1 那么由N的奇偶性决定,  否则后手一定可以使下一个局面为对称的, 因此一定会赢;

    #include<iostream>
    #include<cstdio>
    #include<cstring>
    
    using namespace std;
    
    int main(){
    
        //freopen("input.txt","r",stdin);
    
        int t,cases=0;
        scanf("%d",&t);
        int n,k;
        while(t--){
            scanf("%d%d",&n,&k);
            printf("Case %d: ",++cases);
            if(k>=n){
                puts("first");
                continue;
            }
            if(k==1){
                if(n&1)
                    puts("first");
                else
                    puts("second");
            }else   //当k>=2时,后手一定可以使下一个局面为对称的, 因此一定会赢
                puts("second");
        }
        return 0;
    }
  • 相关阅读:
    python-进程池实例
    python-进程通过队列模拟数据的下载
    python-多进程模板
    python-多线程同步中创建互斥锁解决资源竞争的问题
    CentOS6.5配置网络
    解决CentOS系统Yum出现"Cannot find a valid baseurl for repo"问题
    CentOS 6.5安装图形界面
    Centos安装git
    Web前端优化,提高加载速度
    谁说写代码的不懂生活
  • 原文地址:https://www.cnblogs.com/jackge/p/3232482.html
Copyright © 2011-2022 走看看