zoukankan      html  css  js  c++  java
  • ZOJ Problem Set

    ZOJ Problem Set - 1093
    Monkey and Banana

    Time Limit: 2 Seconds                                    Memory Limit:65536 KB                            

    A group of researchers are designing an experiment to test the IQ of a monkey.  They will hang a banana at the roof of a building, and at the mean time, provide the monkey with some blocks.  If the monkey is clever enough, it shall be able to reach the banana by placing one block on the top another to build a tower and climb up to get its favorite food.

    The researchers have n types of blocks, and an unlimited supply of blocks of each type. Each type-i block was a rectangular solid with linear dimensions (xi, yi, zi).  A block could be reoriented so that any two of its three dimensions  determined the dimensions of the base and the other dimension was the height.

    They want to make sure that the tallest tower possible by stacking blocks can reach the roof.  The problem is that, in building a tower, one block could only be placed on top of another block as long as the two base dimensions of the upper block were both strictly smaller than the corresponding base dimensions of the lower block because there has to be some space for the monkey to step on. This meant, for example, that blocks oriented to have equal-sized bases couldn't be stacked.

    Your job is to write a program that determines the height of the tallest tower the  monkey can build with a given set of blocks.

    Input Specification

    The input file will contain one or more test cases. The first line of each test case contains an integern,
    representing the number of different blocks in the following data set. The maximum value forn is 30.
    Each of the next n lines contains three integers representing the valuesxi,yi andzi.
    Input is terminated by a value of zero (0) for n

    Output Specification

    For each test case, print one line containing the case number (they are numbered sequentially starting from 1)  and the height of the tallest possible tower in the format "Casecase: maximum height =height"

    Sample Input

    1
    10 20 30
    2
    6 8 10
    5 5 5
    7
    1 1 1
    2 2 2
    3 3 3
    4 4 4
    5 5 5
    6 6 6
    7 7 7
    5
    31 41 59
    26 53 58
    97 93 23
    84 62 64
    33 83 27
    0
    

    Sample Output

    Case 1: maximum height = 40
    Case 2: maximum height = 21
    Case 3: maximum height = 28
    Case 4: maximum height = 342
    

    贪心算法,只是砖块有点麻烦

    #include<iostream>
    #include<stdio.h>
    #include<algorithm>
    using namespace std;
    struct Box{
    	int len,wid,hei;
    };
    Box box[600];
    bool cmp(Box a,Box b)
    {
    	if(a.len!=b.len)
    	{
    		return a.len>b.len;
    	}
    	else return a.wid>b.wid;
    }
    void oriente(int index,int x,int y,int z)
    {
    	box[index].len=x;
    	box[index].wid=y;
    	box[index].hei=z;
    }
    int main()
    {
    	int n;
    	int cas=0;
    	while(cin>>n&&n!=0)
    	{
    		int number=0;
    		for(int i=0;i<n;i++)
    		{
    			int t1,t2,t3;
    			cin>>t1>>t2>>t3;
    			oriente(number++,t1,t2,t3);
    			oriente(number++,t1,t3,t2);
    			oriente(number++,t2,t1,t3);
    			oriente(number++,t2,t3,t1);
    			oriente(number++,t3,t1,t2);
    			oriente(number++,t3,t2,t1);
    		}
    		sort(box,box+number,cmp);
    		int height[600];
    		for(int i=0;i<number;i++)
    		   height[i]=box[i].hei;
    		int result=0;
    		for(int i=1;i<number;i++)
    		{
    		    int max=0;
    			for(int j=i-1;j>=0;j--)
    			{
    				if(box[j].len>box[i].len&&box[j].wid>box[i].wid&&max<height[j])
    				{
    				  max=height[j];
    				}
    			}
    			height[i]+=max;
    			if(result<height[i])
    			   result=height[i];
    		}
    		cout<<"Case "<<++cas<<": maximum height = "<<result<<endl;
    	}
    }


     

  • 相关阅读:
    excel成绩统计公式
    freebsd Cacti
    图片处理程序
    php 图片水印+文字水印函数,但是不能设置透明
    PHP计算两个时间之差的函数(年,月,周,日,小时,分钟,秒数)
    php图片水印(可以设置透明度)
    使用函数递归实现基于PHP和MySQL的动态树型菜单[转]
    PHP实现MYSQL备份
    FreeBSD备忘录转载
    超级简单但超级实用的 PHP 的 mysql 类
  • 原文地址:https://www.cnblogs.com/jackwuyongxing/p/3366500.html
Copyright © 2011-2022 走看看