zoukankan      html  css  js  c++  java
  • ZOJ Problem Set

    ZOJ Problem Set - 1049
    I Think I Need a Houseboat

    Time Limit: 2 Seconds                                     Memory Limit: 65536 KB                            

    Fred Mapper is considering purchasing some land in Louisiana to build his house   on. In the process of investigating the land, he learned that the state of Louisiana   is actually shrinking by 50 square miles each year, due to erosion caused by   the Mississippi River. Since Fred is hoping to live in this house the rest of   his life, he needs to know if his land is going to be lost to erosion.

      After doing more research, Fred has learned that the land that is being lost   forms a semicircle. This semicircle is part of a circle centered at (0,0), with   the line that bisects the circle being the X axis. Locations below the X axis   are in the water. The semicircle has an area of 0 at the beginning of year 1.   (Semicircle illustrated in the Figure.)


    Input Format:

      The first line of input will be a positive integer indicating how many data   sets will be included (N).

      Each of the next N lines will contain the X and Y Cartesian coordinates of the   land Fred is considering. These will be floating point numbers measured in miles.   The Y coordinate will be non-negative. (0,0) will not be given.


    Output Format:

      For each data set, a single line of output should appear. This line should take   the form of:

    ��Property N: This property will begin eroding in year Z.��

    Where N is the data set (counting from 1), and Z is the first year (start from   1) this property will be within the semicircle AT THE END OF YEAR Z. Z must   be an integer.

      After the last data set, this should print out ��END OF OUTPUT.��

    Notes:

      1. No property will appear exactly on the semicircle boundary: it will either   be inside or outside.

      2. This problem will be judged automatically. Your answer must match exactly,   including the capitalization, punctuation, and white-space. This includes the   periods at the ends of the lines.

      3. All locations are given in miles.


    Sample Input:

      2
      1.0 1.0
      25.0 0.0


    Sample Output:

      Property 1: This property will begin eroding in year 1.
      Property 2: This property will begin eroding in year 20.
      END OF OUTPUT.

    AC代码:

    #include<iostream>
    #include<stdio.h>
    using namespace std;
    int main()
    {
     int cas;
     int count=0;
     cin>>cas;
     while(cas--)
     {
      float x,y;
      count++;
      cin>>x>>y;
      int r=(int )(x*x+y*y)*3.1415/100+1;
      cout<<"Property "<<count<<": This property will begin eroding in year "<<r<<"."<<endl;
      if(cas==0)
      {
       cout<<"END OF OUTPUT."<<endl;
      }
     }
    }

  • 相关阅读:
    Keras分类问题
    Keras预测股票
    Tensflow预测股票实例
    estimator = KerasClassifier
    keras CNN解读
    Windows下Python安装: requires numpy+mkl 和ImportError: cannot import name NUMPY_MKL
    Tensorflow RNN_LSTM实例
    同时安装python2.7和python3.5
    oracle 杀掉当前用户的进程
    IMP导入时的错误以及解决办法
  • 原文地址:https://www.cnblogs.com/jackwuyongxing/p/3366515.html
Copyright © 2011-2022 走看看