zoukankan      html  css  js  c++  java
  • ZOJ Problem Set -1259 Rails

    Rails

    Time Limit: 2 Seconds                                     Memory Limit: 65536 KB                            

    There is a famous railway station in PopPush City. Country there is incredibly   hilly. The station was built in last century. Unfortunately, funds were extremely   limited that time. It was possible to establish only a surface track. Moreover,   it turned out that the station could be only a dead-end one (see picture) and   due to lack of available space it could have only one track.

    The local tradition is that every train arriving from the direction A continues   in the direction B with coaches reorganized in some way. Assume that the train   arriving from the direction A has N <= 1000 coaches numbered in increasing   order 1, 2, ..., N. The chief for train reorganizations must know whether it   is possible to marshal coaches continuing in the direction B so that their order   will be a1, a2, ..., aN. Help him and write a program that decides whether it   is possible to get the required order of coaches. You can assume that single   coaches can be disconnected from the train before they enter the station and   that they can move themselves until they are on the track in the direction B.   You can also suppose that at any time there can be located as many coaches as   necessary in the station. But once a coach has entered the station it cannot   return to the track in the direction A and also once it has left the station   in the direction B it cannot return back to the station.


    Input

      The input consists of blocks of lines. Each block except the last describes   one train and possibly more requirements for its reorganization. In the first   line of the block there is the integer N described above. In each of the next   lines of the block there is a permutation of 1, 2, ..., N. The last line of   the block contains just 0.

      The last block consists of just one line containing 0.


    Output

       The output contains the lines corresponding to the lines with permutations in   the input. A line of the output contains Yes if it is possible to marshal the   coaches in the order required on the corresponding line of the input. Otherwise   it contains No. In addition, there is one empty line after the lines corresponding   to one block of the input. There is no line in the output corresponding to the   last ``null'' block of the input.


    Sample Input

    5
      1 2 3 4 5
      5 4 1 2 3
      0
      6
      6 5 4 3 2 1
      0
      0


    Sample Output

    Yes
      No

    Yes


                                            Source: Central Europe 1997

    AC代码:

    #include<iostream>
    #include<stdio.h>
    #include<stack>
    using namespace std;
    int main()
    {
     int m,n;
     //int cas=0;
     while(cin>>n)
     {
       if(n==0)break;
       //cas++;
      // if(cas!=1)cout<<endl;
       while(1)
       {
      stack<int>s;
      bool flag=true;
      int j=1;
      bool quit=false;
      for(int i=1;i<=n;i++)
      {
       int t;cin>>t;
       if(t==0)
       {
        quit=true;
        break;
       }
       while(1)
       {
        if(s.empty()||s.top()!=t)
        {
         if(j>n)
         {
           flag=false;
           break;
         }
         s.push(j);
         j++;
        }
        else if(s.top()==t)
        {
         s.pop();
         break;
        }
       }
      }
      if(quit)
      {
       cout<<endl;
       break;
      }
      if(flag)cout<<"Yes"<<endl;
      else cout<<"No"<<endl;
      }
     }
    }

  • 相关阅读:
    how to read openstack code: loading process
    how to read openstack code: request extension
    how to read openstack code: action extension
    b站刷赞 B站刷赞工具 bilibili评论刷赞 b站点赞
    利用邓西百度网盘消息群发工具对百度网盘的群组、好友进行管理,批量分享文件
    如何利用邓西百度网盘批量转存检测工具批量检测百度网盘失效分享链接
    如何使用邓西百度网盘批量重命名工具对百度网盘中的文件进行批量改名、删除等
    如何利用邓西百度网盘消息群发工具批量删除百度网盘单向好友
    如何利用工具自动通过百度网盘好友请求并发送消息或文件
    邓西百度网盘批量保存检测工具高级用法之分享链接以指定名称保存
  • 原文地址:https://www.cnblogs.com/jackwuyongxing/p/3366518.html
Copyright © 2011-2022 走看看