zoukankan      html  css  js  c++  java
  • hdu3006之位压缩

    The Number of set

    Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
    Total Submission(s): 1002    Accepted Submission(s): 626

    Problem Description
    Given you n sets.All positive integers in sets are not less than 1 and not greater than m.If use these sets to combinate the new set,how many different new set you can get.The given sets can not be broken.
     
    Input
    There are several cases.For each case,the first line contains two positive integer n and m(1<=n<=100,1<=m<=14).Then the following n lines describe the n sets.These lines each contains k+1 positive integer,the first which is k,then k integers are given. The input is end by EOF.
     
    Output
    For each case,the output contain only one integer,the number of the different sets you get.
     
    Sample Input
    4 4 1 1 1 2 1 3 1 4 2 4 3 1 2 3 4 1 2 3 4
     
    Sample Output
    15 2
     

    分析:由于m较小,所以可以用相应的位记录出现的数,这样每一个集合就可以用一个数表示了,能够成的集合也就是这些书进行|运算后得到的所有不同数个数了

    #include<iostream>
    #include<cstdio>
    #include<cstdlib>
    #include<cstring>
    #include<string>
    #include<queue>
    #include<algorithm>
    #include<map>
    #include<iomanip>
    #define INF 99999999
    using namespace std;
    
    const int MAX=1<<15;
    bool mark[MAX];
    int s[MAX];
    
    int main(){
    	int n,m,k,a;
    	while(cin>>n>>m){
    		m=1<<(m+1);
    		memset(s,0,sizeof s);
    		memset(mark,false,sizeof mark);
    		mark[0]=true;
    		for(int i=0;i<n;++i){
    			cin>>k;
    			while(k--){
    				cin>>a;
    				s[i]=s[i]|(1<<a);
    			}
    			for(int j=0;j<m;++j){
    				if(mark[j])mark[s[i]|j]=true;
    			}
    		}
    		int num=0;
    		for(int j=1;j<m;++j)num+=mark[j];
    		cout<<num<<endl;
    	}
    	return 0;
    }
  • 相关阅读:
    介绍Collection框架的结构;Collection 和 Collections的区别
    Mybites和hibernate的优缺点和区别2
    Mybites和hibernate的优缺点和区别
    AJAX如何获取从前台传递过来的数据然后在通过servle传递给后台
    list map set 集合的区别
    乐观锁和悲观锁的区别
    python生产消费Kafka
    python类型转换
    python实现远程方法调用
    Scala常用数据结构
  • 原文地址:https://www.cnblogs.com/james1207/p/3266635.html
Copyright © 2011-2022 走看看