zoukankan      html  css  js  c++  java
  • TJU Easier Done than Said?

    Password security is a tricky thing. Users prefer simple passwords that are easy to remember (like  buddy ), but such passwords are often insecure. Some sites use random computer-generated passwords (like  xvtpzyo ), but users have a hard time remembering them and sometimes leave them written on notes stuck to their computer. One potential solution is to generate "pronounceable" passwords that are relatively secure but still easy to remember.

     

    FnordCom is developing such a password generator. You work in the quality control department, and it's your job to test the generator and make sure that the passwords are acceptable. To be acceptable, a password must satisfy these three rules:

    1. It must contain at least one vowel.
    2. It cannot contain three consecutive vowels or three consecutive consonants.
    3. It cannot contain two consecutive occurrences of the same letter, except for 'ee' or 'oo'.

    (For the purposes of this problem, the vowels are 'a', 'e', 'i', 'o', and 'u'; all other letters are consonants.) Note that these rules are not perfect; there are many common/pronounceable words that are not acceptable.

    The input consists of one or more potential passwords, one per line, followed by a line containing only the word 'end' that signals the end of the file. Each password is at least one and at most twenty letters long and consists only of lowercase letters. For each password, output whether or not it is acceptable, using the precise format shown in the example.

    Sample Input

    a
    tv
    ptoui
    bontres
    zoggax
    wiinq
    eep
    houctuh
    end
    

    Sample Output

    <a> is acceptable.
    <tv> is not acceptable.
    <ptoui> is not acceptable.
    <bontres> is not acceptable.
    <zoggax> is not acceptable.
    <wiinq> is not acceptable.
    <eep> is acceptable.
    <houctuh> is acceptable.
    
    
    
    
    
    
    
    题意概述:题目意思比较简单,如果看不懂,那说明真的该去补习一下英语了。题目意思,给定一个字符串,长度在1到20之间,包括1和20.需要满足3个条件才是可接受的,否则是不可接受的。条件一:必须含有一个元音字母;条件二:不能有连续三个元音或辅音字母;条件三:不能有连续两个相同字母,连续的oo和ee除外。
    
    
    解题思路:用三个bool型变量分别表示三个条件是否成立。若字符串中有元音字母,则flag1=true;若没有连续的三个辅音或元音flag2=true;若没有连续两个相同的字母,flag3=true。对了,不能忘记字符串长度为1的情况,此时若为元音,则可以接受。
    
    
    源代码:
    
    
    #include<iostream>
    #include<string>
    using namespace std;
    
    
    bool isVowel(char c)             //判断字符c是否为元音字母,是则返回true 
    {
         bool flag=false;
         if(c=='a')flag=true;
         else if(c=='o')flag=true;
         else if(c=='e')flag=true;
         else if(c=='i')flag=true;
         else if(c=='u')flag=true;
         return flag;
    }
    
    
    bool isSame(string s)           //判断是否有连续两个相同字母,若没有则返回true 
    {
         bool flag=true;
         for(int i=0;i<s.size()-1;++i)
         {
               if(s[i]==s[i+1]&&s[i]!='e'&&s[i]!='o')
               {
                    flag=false;
                    break;
               }
         }
         return flag;
    }
    
    
    int main()
    {
        int flag[20];
        string s;
        while(cin>>s&&s!="end")
        {
              bool flag1=false,flag2=false,flag3=true;
              for(int i=0;i<20;++i)                   //用于存储相同类别的字母的长度 
                   flag[i]=1;
              
              if(s.size()==1&&isVowel(s[0]))cout<<'<'<<s<<'>'<<" is acceptable."<<endl;      //长度为1的情况 
              else if(s.size()==1&&!isVowel(s[0]))cout<<'<'<<s<<'>'<<" is not acceptable."<<endl;
              
              else if(s.size()>1)                            //长度大于1的情况 
              {
                   int flag1=false,flag2=true,flag3=true;    
                   if(isVowel(s[0]))flag1=true;
                   
                   for(int i=1;i<s.size();++i)
                   {
                        //若是元音字母,则是flag1=true 
                        if(isVowel(s[i]))flag1=true;
                        //连续两个相同字母 ,则使对应的flag[i]=flag[i-1]+1 
                        if( (isVowel(s[i-1])&&isVowel(s[i])) || (!isVowel(s[i-1])&&!isVowel(s[i])) )flag[i]=++flag[i-1];
                        //若相同类别的字母最大长度大于2,则使flag3=false,并退出循环 
                        if(flag[i]>2){flag3=false;break;}
                   }
                   flag2=isSame(s);        //判断是否有连续相同的字符 
                   if(flag1 && flag2 && flag3)cout<<'<'<<s<<'>'<<" is acceptable."<<endl;
                   else cout<<'<'<<s<<'>'<<" is not acceptable."<<endl;
              }
        }
        return 0;
    } 
    
    
    
    
    

  • 相关阅读:
    element-ui获取table行数据
    去掉输入框的边框以及在显示获取焦点时的边框+jq日期选择器
    需要ui的小伙伴看过来(这篇博客只有一个链接希望对大家有用)
    vue获取当前对象
    FlashFXP用到的功能
    VS Code做项目的笔记
    单点登陆
    idea中自动生成实体类
    VSCode安装
    数组排序
  • 原文地址:https://www.cnblogs.com/james1207/p/3367678.html
Copyright © 2011-2022 走看看