zoukankan      html  css  js  c++  java
  • hdu 4287Intelligent IME(简单hash)

    Intelligent IME

    Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
    Total Submission(s): 1810    Accepted Submission(s): 897

    Problem Description
    We all use cell phone today. And we must be familiar with the intelligent English input method on the cell phone. To be specific, the number buttons may correspond to some English letters respectively, as shown below:
    2 : a, b, c    3 : d, e, f    4 : g, h, i    5 : j, k, l    6 : m, n, o    
    7 : p, q, r, s  8 : t, u, v    9 : w, x, y, z
    When we want to input the word “wing”, we press the button 9, 4, 6, 4, then the input method will choose from an embedded dictionary, all words matching the input number sequence, such as “wing”, “whoi”, “zhog”. Here comes our question, given a dictionary, how many words in it match some input number sequences?
     
    Input
    First is an integer T, indicating the number of test cases. Then T block follows, each of which is formatted like this:
    Two integer N (1 <= N <= 5000), M (1 <= M <= 5000), indicating the number of input number sequences and the number of words in the dictionary, respectively. Then comes N lines, each line contains a number sequence, consisting of no more than 6 digits. Then comes M lines, each line contains a letter string, consisting of no more than 6 lower letters. It is guaranteed that there are neither duplicated number sequences nor duplicated words.
     
    Output
    For each input block, output N integers, indicating how many words in the dictionary match the corresponding number sequence, each integer per line.
     
    Sample Input
    1 3 5 46 64448 74 go in night might gn
     
    Sample Output
    3 2 0
     
    Source
     


      题目意思就不多说了,将下面的字符串hash映射到上面的数字上即可。

    AC代码:
    #include<iostream>
    #include<cstring>
    using namespace std;
    int hash1[1000005];
    int a[5005];
    char b[5005][8];
    
    int cal(char *s)
    {
        int tmp=0;
        int len=strlen(s),i;
        for(i=0;i<len;i++)
        {
            if(s[i]>='a'&&s[i]<='c')       tmp=tmp*10+2;
            else if(s[i]>='d'&&s[i]<='f') tmp=tmp*10+3;
            else if(s[i]>='g'&&s[i]<='i') tmp=tmp*10+4;
            else if(s[i]>='j'&&s[i]<='l') tmp=tmp*10+5;
            else if(s[i]>='m'&&s[i]<='o') tmp=tmp*10+6;
            else if(s[i]>='p'&&s[i]<='s') tmp=tmp*10+7;
            else if(s[i]>='t'&&s[i]<='v') tmp=tmp*10+8;
            else if(s[i]>='w'&&s[i]<='z') tmp=tmp*10+9;
        }
        return tmp;
    }
    
    int main()
    {
        int tes,i;
        cin>>tes;
        while(tes--)
        {
            int n,m;
            cin>>n>>m;
            for(i=0;i<n;i++)
                cin>>a[i];   //存放数字
            for(i=0;i<m;i++)
                cin>>b[i];
            memset(hash1,0,sizeof(hash1));
            for(i=0;i<m;i++)
                hash1[cal(b[i])]++;
            for(i=0;i<n;i++)
                cout<<hash1[a[i]]<<endl;
        }
        return 0;
    }
    
    //406MS
    


  • 相关阅读:
    替换configparser 中指定的值
    configparser 读取与赋值
    接口测试第五步 --》 拼接url
    接口测试第四步 --》 封装excel
    接口测试第三步 --》 封装请求方法
    接口测试第二步 --》 推荐定义一个log 文件
    超级直观理解tcp握手
    crash 潜水
    提高MySQL查询速度
    JSON文件存入MySQL数据库
  • 原文地址:https://www.cnblogs.com/james1207/p/3395193.html
Copyright © 2011-2022 走看看