zoukankan      html  css  js  c++  java
  • 杭电1003 MAX SUN

    Problem Description
    Given a sequence a[1],a[2],a[3]......a[n], your job is to calculate the max sum of a sub-sequence. For example, given (6,-1,5,4,-7), the max sum in this sequence is 6 + (-1) + 5 + 4 = 14.
     
    Input
    The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line starts with a number N(1<=N<=100000), then N integers followed(all the integers are between -1000 and 1000).

    Output

    For each test case, you should output two lines. The first line is "Case #:", # means the number of the test case. The second line contains three integers, the Max Sum in the sequence, the start position of the sub-sequence, the end position of the sub-sequence. If there are more than one result, output the first one. Output a blank line between two cases.
     
    Sample Input
    2 5 6 -1 5 4 -7 7 0 6 -1 1 -6 7 -5
     
    Sample Output
    Case 1: 14 1 4 Case 2: 7 1 6
     

    代码如下:

    #include <iostream>
    using namespace std;
    int main()
    {
    	int t;
    	cin>>t;
    	if(t>=0&&t<=20)
    	{
    		for(int i=1;i<=t;i++)
    		{
    			int first,second,temp=1;
    			int sum=0,max=-1001;
    			int n,x;
    			cin>>n;
    			for(int j=1;j<=n;j++)
    			{
    				cin>>x;
    				sum=sum+x;
    				if(max<sum)
    				{
    					max=sum;
    					first=temp;
    					second=j;
    				}
    				if(sum<0)
    				{
    					sum=0;
    					temp=j+1;
    				}
    			}
    			cout<<"Case "<<i<<":"<<endl;
    			cout<<max<<" "<<first<<" "<<second<<endl;
    			if(i<t)
    				cout<<endl;
    		}
    	}
    	return 0;
    }


     

  • 相关阅读:
    国庆清北 Day5 T3 holyshit
    清北国庆Day4 T2 r
    清北国庆Day4 T2 y
    国庆清北Day4 DP 题目
    国庆清北 DP
    国庆清北 搜索
    国庆清北 图论
    国庆清北 数据结构
    python爬虫学习:网页采集器、豆瓣电影爬取、百度翻译
    入门爬虫-requests模块
  • 原文地址:https://www.cnblogs.com/james1207/p/3400207.html
Copyright © 2011-2022 走看看