zoukankan      html  css  js  c++  java
  • POJ_3278_Catch That Cow

    Catch That Cow
    Time Limit: 2000MS   Memory Limit: 65536K
    Total Submissions: 54911   Accepted: 17176

    Description

    Farmer John has been informed of the location of a fugitive cow and wants to catch her immediately. He starts at a point N (0 ≤ N ≤ 100,000) on a number line and the cow is at a point K (0 ≤ K ≤ 100,000) on the same number line. Farmer John has two modes of transportation: walking and teleporting.

    * Walking: FJ can move from any point X to the points - 1 or + 1 in a single minute
    * Teleporting: FJ can move from any point X to the point 2 × X in a single minute.

    If the cow, unaware of its pursuit, does not move at all, how long does it take for Farmer John to retrieve it?

    Input

    Line 1: Two space-separated integers: N and K

    Output

    Line 1: The least amount of time, in minutes, it takes for Farmer John to catch the fugitive cow.

    Sample Input

    5 17

    Sample Output

    4

    Hint

    The fastest way for Farmer John to reach the fugitive cow is to move along the following path: 5-10-9-18-17, which takes 4 minutes.
    题解:
    宽度优先搜索bfs
    代码:
    #include<iostream>
    #include<queue>
    #include<cstring>
    using namespace std;
    #define N 100005
    struct Node
    {
        int x;
        int step;
    };
    queue<struct Node>q;
    bool visit[N];
    
    bool ok(int x)
    {
        if(x>=0 && x<=100000)
            return 1;
        return 0;
    }
    
    int cal(int i,int x)
    {
        if(i==0)
            return x+1;
        else if(i==1)
            return x-1;
        else
            return x*2;
    }
    void bfs(int a,int b)
    {
        memset(visit,0,sizeof(visit));
        while(!q.empty())
        {
            q.pop();
        }
        Node aa;
        aa.step=1;
        aa.x=a;
        q.push(aa);
        visit[aa.x]=1;
        while(!q.empty())
        {
            Node tmp=q.front();
            q.pop();
            for(int i=0; i<3; i++)
            {
                int y=cal(i,tmp.x);
                if(ok(y)&&!visit[y])
                {
                    if(y==b)
                        cout<<tmp.step<<endl;
                    else
                    {
                        aa.step=tmp.step+1;
                        aa.x=y;
                        q.push(aa);
    
                    }
              visit[y]
    =1; } } } } int main() { int n,k; cin>>n>>k; if(k>n) bfs(n,k); else cout<<(n-k); return 0; }
  • 相关阅读:
    JMS基本概念
    SSH项目整合
    SSH框架搭建问题总结
    web项目中classPath指的是哪里?
    web项目中配置文件的加载顺序
    分布式电商系统项目总结
    关于javaweb中图片的存储问题
    商品详情页面的显示
    利用solr实现商品的搜索功能
    SSM框架的搭建与测试
  • 原文地址:https://www.cnblogs.com/jasonlixuetao/p/4531101.html
Copyright © 2011-2022 走看看