zoukankan      html  css  js  c++  java
  • POJ_1163_The triangle

    The Triangle
    Time Limit: 1000MS   Memory Limit: 10000K
    Total Submissions: 40079   Accepted: 24144

    Description

    7
    3 8
    8 1 0
    2 7 4 4
    4 5 2 6 5

    (Figure 1)
    Figure 1 shows a number triangle. Write a program that calculates the highest sum of numbers passed on a route that starts at the top and ends somewhere on the base. Each step can go either diagonally down to the left or diagonally down to the right. 

    Input

    Your program is to read from standard input. The first line contains one integer N: the number of rows in the triangle. The following N lines describe the data of the triangle. The number of rows in the triangle is > 1 but <= 100. The numbers in the triangle, all integers, are between 0 and 99.

    Output

    Your program is to write to standard output. The highest sum is written as an integer.

    Sample Input

    5
    7
    3 8
    8 1 0 
    2 7 4 4
    4 5 2 6 5

    Sample Output

    30
    代码:
    #include<iostream>
    #include<stdio.h>
    #include<string.h>
    #include<algorithm>
    #define MAXN 105
    using namespace std;
    
    int tri[MAXN][MAXN];
    int sum[MAXN][MAXN];
    
    int main()
    {
        int i,j;
        int n,maxsum=0;
        cin>>n;
        for(i=1;i<=n;i++)
            for(j=1;j<=i;j++)
                scanf("%d",&tri[i][j]);
        memset(sum,0,sizeof(sum));
        for(i=1;i<=n;i++)
            for(j=1;j<=i;j++)
            {
                if(i==1)
                    sum[i][j]=tri[i][j];
                else if(j==1)
                    sum[i][j]=sum[i-1][j]+tri[i][j];
                else if(j==i)
                    sum[i][j]=sum[i-1][j-1]+tri[i][j];
                else if(j<i)
                    sum[i][j]=max(sum[i-1][j-1]+tri[i][j],sum[i-1][j]+tri[i][j]);
            }
        for(i=1;i<=n;i++)
            maxsum=max(maxsum,sum[n][i]);
        cout<<maxsum<<endl;
        return 0;
    }
  • 相关阅读:
    linux mint 17编译android 2.3.1错误记录
    android字母索引实现ListView定位
    android实现emoji输入
    shell管道与重定向
    c3p0配置记录
    ubuntu13 eclipse菜单栏失效解决
    Proxy实现java动态代理
    ubuntu13启动屏幕亮度0解决方法
    cookie和session笔记
    linux mysql中文乱码解决
  • 原文地址:https://www.cnblogs.com/jasonlixuetao/p/4531132.html
Copyright © 2011-2022 走看看