zoukankan      html  css  js  c++  java
  • POJ_1611_The Suspect

    The Suspects
    Time Limit: 1000MS   Memory Limit: 20000K
    Total Submissions: 25149   Accepted: 12329

    Description

    Severe acute respiratory syndrome (SARS), an atypical pneumonia of unknown aetiology, was recognized as a global threat in mid-March 2003. To minimize transmission to others, the best strategy is to separate the suspects from others. 
    In the Not-Spreading-Your-Sickness University (NSYSU), there are many student groups. Students in the same group intercommunicate with each other frequently, and a student may join several groups. To prevent the possible transmissions of SARS, the NSYSU collects the member lists of all student groups, and makes the following rule in their standard operation procedure (SOP). 
    Once a member in a group is a suspect, all members in the group are suspects. 
    However, they find that it is not easy to identify all the suspects when a student is recognized as a suspect. Your job is to write a program which finds all the suspects.

    Input

    The input file contains several cases. Each test case begins with two integers n and m in a line, where n is the number of students, and m is the number of groups. You may assume that 0 < n <= 30000 and 0 <= m <= 500. Every student is numbered by a unique integer between 0 and n−1, and initially student 0 is recognized as a suspect in all the cases. This line is followed by m member lists of the groups, one line per group. Each line begins with an integer k by itself representing the number of members in the group. Following the number of members, there are k integers representing the students in this group. All the integers in a line are separated by at least one space. 
    A case with n = 0 and m = 0 indicates the end of the input, and need not be processed.

    Output

    For each case, output the number of suspects in one line.

    Sample Input

    100 4
    2 1 2
    5 10 13 11 12 14
    2 0 1
    2 99 2
    200 2
    1 5
    5 1 2 3 4 5
    1 0
    0 0

    Sample Output

    4
    1
    1

    Source

    题解:合并集合
    代码:使用并查集
    #include<iostream>
    using namespace std;
    int father[30010];
    int input[30010];
    int find(int n)
    {
        if(father[n]!=n)
            father[n]=find(father[n]);
        return father[n];
    }
    void merge(int a,int b)
    {
        int x,y;
        x=find(a);
        y=find(b);
        if(x!=y)
            father[x]=y;
    }
    int main()
    {
        int n,m,k,num;
        int i,j;
        while(1)
        {
    
            cin>>n>>m;
            for(i=0; i<n; i++)
                father[i]=i;
            if(n==0&&m==0)
                break;
            while(m--)
            {
                cin>>num;
                for(i=0; i<num; i++)
                    cin>>input[i];
                for(i=1; i<num; i++)
                    merge(input[0],input[i]);
            }
            int cnt=1;
            for(i=1; i<n; i++)
                if(find(father[0])==find(father[i]))
                    cnt++;
            cout<<cnt<<endl;
        }
        return 0;
    }
  • 相关阅读:
    系统消息系统公告数据建模
    Chrome部分站点无法启用Flash问题
    使用netstat命令查看端口的使用情况
    Jave基本数据类型
    Mac下Tomcat安装&配置&80默认端口设置
    React学习及实例开发(一)——开始(转载)
    jQuery、layer实现弹出层的打开、关闭功能实例详解
    jQuery获取节点和子节点文本的方法
    jquery 获取$("#id").text()里面的值 需要进行去空格去换行符操作
    ES6数组新增的几个方法
  • 原文地址:https://www.cnblogs.com/jasonlixuetao/p/4540179.html
Copyright © 2011-2022 走看看