zoukankan      html  css  js  c++  java
  • poj1577 Falling Leaves

     Falling Leaves
    Time Limit:1000MS     Memory Limit:10000KB     64bit IO Format:%I64d & %I64u

    Description

     
    Figure 1

    Figure 1 shows a graphical representation of a binary tree of letters. People familiar with binary trees can skip over the definitions of a binary tree of letters, leaves of a binary tree, and a binary search tree of letters, and go right to The problem. 

    A binary tree of letters may be one of two things: 
    1. It may be empty. 
    2. It may have a root node. A node has a letter as data and refers to a left and a right subtree. The left and right subtrees are also binary trees of letters.

    In the graphical representation of a binary tree of letters: 
    1. Empty trees are omitted completely. 
    2. Each node is indicated by 
      • Its letter data, 
      • A line segment down to the left to the left subtree, if the left subtree is nonempty, 
      • A line segment down to the right to the right subtree, if the right subtree is nonempty.

    A leaf in a binary tree is a node whose subtrees are both empty. In the example in Figure 1, this would be the five nodes with data B, D, H, P, and Y. 

    The preorder traversal of a tree of letters satisfies the defining properties: 
    1. If the tree is empty, then the preorder traversal is empty. 
    2. If the tree is not empty, then the preorder traversal consists of the following, in order 
      • The data from the root node, 
      • The preorder traversal of the root's left subtree, 
      • The preorder traversal of the root's right subtree.

    The preorder traversal of the tree in Figure 1 is KGCBDHQMPY. 

    A tree like the one in Figure 1 is also a binary search tree of letters. A binary search tree of letters is a binary tree of letters in which each node satisfies: 

    The root's data comes later in the alphabet than all the data in the nodes in the left subtree. 

    The root's data comes earlier in the alphabet than all the data in the nodes in the right subtree. 

    The problem: 

    Consider the following sequence of operations on a binary search tree of letters 

    Remove the leaves and list the data removed 
    Repeat this procedure until the tree is empty 
    Starting from the tree below on the left, we produce the sequence of trees shown, and then the empty tree 

    by removing the leaves with data 

    BDHPY 
    CM 
    GQ 


    Your problem is to start with such a sequence of lines of leaves from a binary search tree of letters and output the preorder traversal of the tree.

    Input

    The input will contain one or more data sets. Each data set is a sequence of one or more lines of capital letters. 

    The lines contain the leaves removed from a binary search tree in the stages described above. The letters on a line will be listed in increasing alphabetical order. Data sets are separated by a line containing only an asterisk ('*'). 

    The last data set is followed by a line containing only a dollar sign ('$'). There are no blanks or empty lines in the input.

    Output

    For each input data set, there is a unique binary search tree that would produce the sequence of leaves. The output is a line containing only the preorder traversal of that tree, with no blanks.

    Sample Input

    BDHPY
    CM
    GQ
    K
    *
    AC
    B
    $

    Sample Output

    KGCBDHQMPY
    BAC
    题目很水,和刚才那题水题差不多,这题只要把输入从下往上构建二叉树,然后前序输出就行了。
    一次A过。。。
    AC代码:
    #include<cstdio>
    #include<cstdlib>
    #include<cstring>
    #define MAXN 30
    
    typedef struct TNode
    {
    	char v;
    	TNode *l, *r;
    }Node;
    
    Node* newnd(char ch)
    {
    	Node* u = (Node*) malloc(sizeof(Node));
    	if (u != NULL)
    	{
    		u->v = ch;
    		u->l = u->r = NULL;
    	}
    	return u;
    }
    
    Node* addnd(char val, Node* nd)
    {
    	if (nd == NULL)
    		nd = newnd(val);
    	else
    	{
    		if (val >= nd->v)
    			nd->r = addnd(val, nd->r);
    		else
    			nd->l = addnd(val, nd->l);
    	}
    	return nd;
    }
    
    void Preorder(Node* nd)
    {
    	if (nd != NULL)
    	{
    		printf("%c", nd->v);
    		Preorder(nd->l);
    		Preorder(nd->r);
    	}
    }
    
    int main()
    {
    	char str[MAXN][MAXN] = {0}, cnt = 0;
    	Node* root = NULL;
    	while(scanf("%s", str[cnt]))
    	{
    		char tmp = str[cnt][0];
    		if (tmp == '*' || tmp == '$')
    		{
    			for (int i = cnt - 1; i >= 0; i--)
    				for (int j = 0; j < strlen(str[i]); j++)
    					root = addnd(str[i][j], root);
    			Preorder(root);
    			printf("\n");
    			memset(str, 0, sizeof(str));
    			root = NULL;
    			cnt = 0;
    		}
    		else
    			cnt++;
    		if (tmp == '$')
    			break;
    	}
    	return 0;
    }


  • 相关阅读:
    (二)vue的生命周期及相关的运行流程
    Vue接入百度地图显示及相关操作
    前端开发环境的介绍
    更改博客园的样式
    Ant Design of Vue 组件库的使用
    Vue 更换页面图标和title
    (四) Vue 相关的路由配置(及子路由配置)
    SVN创建分支的相关操作
    vs code插件自动压缩 min.css
    敲开通往架构师的门
  • 原文地址:https://www.cnblogs.com/java20130723/p/3212175.html
Copyright © 2011-2022 走看看