zoukankan      html  css  js  c++  java
  • 字符串系列——自动物理题

      Artificial Intelligence? 

    Physics teachers in high school often think that problems given as text are more demanding than pure computations. After all, the pupils have to read and understand the problem first!

    So they don't state a problem like ``U=10V, I=5A, P=?" but rather like ``You have an electrical circuit that contains a battery with a voltage of U=10V and a light-bulb. There's an electrical current of I=5A through the bulb. Which power is generated in the bulb?".

    However, half of the pupils just don't pay attention to the text anyway. They just extract from the text what is given: U=10V, I=5A. Then they think: ``Which formulae do I know? Ah yes, P=U*I. Therefore P=10V*5A=500W. Finished."

    OK, this doesn't always work, so these pupils are usually not the top scorers in physics tests. But at least this simple algorithm is usually good enough to pass the class. (Sad but true.)

    Today we will check if a computer can pass a high school physics test. We will concentrate on the P-U-I type problems first. That means, problems in which two of power, voltage and current are given and the third is wanted.


    Your job is to write a program that reads such a text problem and solves it according to the simple algorithm given above.

    Input 

    The first line of the input file will contain the number of test cases.

    Each test case will consist of one line containing exactly two data fields and some additional arbitrary words. A data field will be of the form I=xAU=xV or P=xW, where x is a real number.

    Directly before the unit (AV or W) one of the prefixes m (milli), k (kilo) and M (Mega) may also occur. To summarize it: Data fields adhere to the following grammar:

    DataField ::= Concept '=' RealNumber [Prefix] Unit
    Concept   ::= 'P' | 'U' | 'I'
    Prefix    ::= 'm' | 'k' | 'M'
    Unit      ::= 'W' | 'V' | 'A'
    

    Additional assertions:

    • The equal sign (`=') will never occur in an other context than within a data field.
    • There is no whitespace (tabs,blanks) inside a data field.
    • Either P and UP and I, or U and I will be given.

    Output 

    For each test case, print three lines:

    • a line saying ``Problem #k" where k is the number of the test case
    • a line giving the solution (voltage, power or current, dependent on what was given), written without a prefix and with two decimal places as shown in the sample output
    • a blank line

    Sample Input 

    3
    If the voltage is U=200V and the current is I=4.5A, which power is generated?
    A light-bulb yields P=100W and the voltage is U=220V. Compute the current, please.
    bla bla bla lightning strike I=2A bla bla bla P=2.5MW bla bla voltage?
    

    Sample Output 

    Problem #1
    P=900.00W
    
    Problem #2
    I=0.45A
    
    Problem #3
    U=1250000.00V
    
    
    很水的一题,却WA了几次,跑了好多博客找别人的代码来测试都觉得没问题,最后。。。
    竟然是题目看错了!
    我戳m竟然是毫,我一直以为m和M是一样都是百万。。。
    终于AC。。。
    代码:
    #include<stdio.h>
    #include<string.h>
    
    int main()
    {
        int n, i, j;
        char ch[1000], temp;
    
        scanf("%d", &n);
        getchar();
    
        for (j = 0; j < n; j ++)
        {
            double u = 0, I = 0, p = 0, num = 0;
            printf("Problem #%d\n", j + 1);
    
            for(i = 0; (ch[i] = getchar()) != '='; i ++);
            scanf("%lf", &num);
            scanf("%c", &temp);
            if (temp == 'M')
                num *= 1000000;
            if (temp == 'm')
                num *= .001;
            if (temp == 'k')
                num *= 1000;
            switch(ch[i - 1])
            {
            case 'U':
                u = num;
                break;
            case 'I':
                I = num;
                break;
            case 'P':
                p = num;
                break;
            }
            //second
    //printf("u = %lf i = %lf p = %lf\n", u, I, p);
            for(i = 0;(ch[i] = getchar()) != '='; i ++);
            scanf("%lf", &num);
            scanf("%c", &temp);
            if (temp == 'M')
                num *= 1000000;
            if (temp == 'm')
                num *= .001;
            if (temp == 'k')
                num *= 1000;
            switch(ch[i - 1])
            {
            case 'U':
                u = num;
                break;
            case 'I':
                I = num;
                break;
            case 'P':
                p = num;
                break;
            }
    //printf("u = %lf i = %lf p = %lf\n", u, I, p);
            //judge and calculate
            if (u > 0 && I > 0 && p == 0)
                printf("P=%.2lfW\n", u * I);
            if (p > 0 && I > 0 && u == 0)
                printf("U=%.2lfV\n", p / I);
            if (u > 0 && p > 0 && I == 0)
                printf("I=%.2lfA\n", p / u);
            printf("\n");
        }
        return 0;
    }
    


    代码有点长,因为我录入时,用=判断了两次都是直接复制的。。。
  • 相关阅读:
    ACM
    Java实现排序
    HTML导出Excel文件(兼容IE及所有浏览器)
    WebForm应用log4net记录错误日志——使用线程列队写入
    @RefreshScope 配置方法
    Eclipse oxygen 版本汉化教程
    创建Dynamic Web Project时 显示最新Apache Tomcat 8.0 的方法
    微软汉字转拼音
    Ueditor 前后端分离实现文件上传到独立服务器
    汉字转拼音类(多音字)
  • 原文地址:https://www.cnblogs.com/java20130723/p/3212196.html
Copyright © 2011-2022 走看看