zoukankan      html  css  js  c++  java
  • POJ3009:Curling 2.0(DFS) java程序员

    Curling 2.0
    Time Limit: 1000MS   Memory Limit: 65536K
    Total Submissions: 7490   Accepted: 3127

    Description

    On Planet MM-21, after their Olympic games this year, curling is getting popular. But the rules are somewhat different from ours. The game is played on an ice game board on which a square mesh is marked. They use only a single stone. The purpose of the game is to lead the stone from the start to the goal with the minimum number of moves.

    Fig. 1 shows an example of a game board. Some squares may be occupied with blocks. There are two special squares namely the start and the goal, which are not occupied with blocks. (These two squares are distinct.) Once the stone begins to move, it will proceed until it hits a block. In order to bring the stone to the goal, you may have to stop the stone by hitting it against a block, and throw again.


    Fig. 1: Example of board (S: start, G: goal)

    The movement of the stone obeys the following rules:

    • At the beginning, the stone stands still at the start square.
    • The movements of the stone are restricted to x and y directions. Diagonal moves are prohibited.
    • When the stone stands still, you can make it moving by throwing it. You may throw it to any direction unless it is blocked immediately(Fig. 2(a)).
    • Once thrown, the stone keeps moving to the same direction until one of the following occurs:
      • The stone hits a block (Fig. 2(b), (c)).
        • The stone stops at the square next to the block it hit.
        • The block disappears.
      • The stone gets out of the board.
        • The game ends in failure.
      • The stone reaches the goal square.
        • The stone stops there and the game ends in success.
    • You cannot throw the stone more than 10 times in a game. If the stone does not reach the goal in 10 moves, the game ends in failure.


    Fig. 2: Stone movements

    Under the rules, we would like to know whether the stone at the start can reach the goal and, if yes, the minimum number of moves required.

    With the initial configuration shown in Fig. 1, 4 moves are required to bring the stone from the start to the goal. The route is shown in Fig. 3(a). Notice when the stone reaches the goal, the board configuration has changed as in Fig. 3(b).


    Fig. 3: The solution for Fig. D-1 and the final board configuration

    Input

    The input is a sequence of datasets. The end of the input is indicated by a line containing two zeros separated by a space. The number of datasets never exceeds 100.

    Each dataset is formatted as follows.

    the width(=w) and the height(=h) of the board
    First row of the board

    ...
    h-th row of the board

    The width and the height of the board satisfy: 2 <= w <= 20, 1 <= h <= 20.

    Each line consists of w decimal numbers delimited by a space. The number describes the status of the corresponding square.

    0 vacant square
    1 block
    2 start position
    3 goal position

    The dataset for Fig. D-1 is as follows:

    6 6
    1 0 0 2 1 0
    1 1 0 0 0 0
    0 0 0 0 0 3
    0 0 0 0 0 0
    1 0 0 0 0 1
    0 1 1 1 1 1

    Output

    For each dataset, print a line having a decimal integer indicating the minimum number of moves along a route from the start to the goal. If there are no such routes, print -1 instead. Each line should not have any character other than this number.

    Sample Input

    2 1
    3 2
    6 6
    1 0 0 2 1 0
    1 1 0 0 0 0
    0 0 0 0 0 3
    0 0 0 0 0 0
    1 0 0 0 0 1
    0 1 1 1 1 1
    6 1
    1 1 2 1 1 3
    6 1
    1 0 2 1 1 3
    12 1
    2 0 1 1 1 1 1 1 1 1 1 3
    13 1
    2 0 1 1 1 1 1 1 1 1 1 1 3
    0 0

    Sample Output

    1
    4
    -1
    4
    10
    -1

    Source

    MYCode:
    #include<iostream>
    #include<cstring>
    #include<cstdio>
    using namespace std;
    #define MAX 25
    int map[MAX][MAX];
    int dirt[4][2]={{1,0},{-1,0},{0,1},{0,-1}};
    int ans;
    int n,m;
    int sx,sy,ex,ey;
    void dfs(int x,int y,int step)
    {
        //cout<<"MOVE TO"<<x<<" "<<y<<endl;
        if(step==10)
        return;
        int i;
        int tx,ty;
        for(i=0;i<4;i++)
        {
            tx=x+dirt[i][0];
            ty=y+dirt[i][1];
            while(map[tx][ty]==0&&tx>=1&&tx<=n&&ty>=1&&ty<=m)
            {
                tx+=dirt[i][0];
                ty+=dirt[i][1];
            }
            if(map[tx][ty]==1 && !(tx==x+dirt[i][0]&&ty==y+dirt[i][1]))
            {
                map[tx][ty]=0;
                dfs(tx-dirt[i][0],ty-dirt[i][1],step+1);
                map[tx][ty]=1;
            }
            else if(map[tx][ty]==3)
            {
                if(step+1<ans)
                ans=step+1;
                return;
            }
        }
    }
    int main()
    {
        while(scanf("%d%d",&m,&n)!=EOF)
        {
            if(n==0&&m==0)
            break;
            memset(map,0,sizeof(map));
            int i,j;
            for(i=1;i<=n;i++)
            {
                for(j=1;j<=m;j++)
                {
                    scanf("%d",&map[i][j]);
                    if(map[i][j]==2)
                    {
                        sx=i;
                        sy=j;
                    }
                    else if(map[i][j]==3)
                    {
                        ex=i;
                        ey=j;
                    }
                }
            }
            ans=15;
            map[sx][sy]=0;
            dfs(sx,sy,0);
            if(ans!=15)
            printf("%d\n",ans);
            else
            printf("-1\n");
        }
        //system("pause");
    }
    //
    DFS
    暴力搜索,没有剪枝
    复杂度4^10
    110MS
  • 相关阅读:
    为什么 PHP 程序员应该学习使用 Swoole
    如何优雅的使用和理解线程池
    Redis 数据结构-字符串源码分析
    MySQL多版本并发控制机制(MVCC)-源码浅析
    Spring事务用法示例与实现原理
    J2Cache 和普通缓存框架有何不同,它解决了什么问题?
    Spring Aop之Cglib实现原理详解
    Python中字符串拼接的N种方法
    使用Fiddler抓取到的“姐夫酷”API接口
    [Android]Space控件的应用场景
  • 原文地址:https://www.cnblogs.com/java20130725/p/3215875.html
Copyright © 2011-2022 走看看