zoukankan      html  css  js  c++  java
  • POJ3273:Monthly Expense(二分) java程序员

    Monthly Expense
    Time Limit: 2000MS Memory Limit: 65536K
    Total Submissions: 9302 Accepted: 3823

    Description

    Farmer John is an astounding accounting wizard and has realized he might run out of money to run the farm. He has already calculated and recorded the exact amount of money (1 ≤moneyi ≤ 10,000) that he will need to spend each day over the nextN (1 ≤ N ≤ 100,000) days.

    FJ wants to create a budget for a sequential set of exactlyM (1 ≤MN) fiscal periods called "fajomonths". Each of these fajomonths contains a set of 1 or more consecutive days. Every day is contained in exactly one fajomonth.

    FJ's goal is to arrange the fajomonths so as to minimize the expenses of the fajomonth with the highest spending and thus determine his monthly spending limit.

    Input

    Line 1: Two space-separated integers:N andM
    Lines 2..N+1: Line i+1 contains the number of dollars Farmer John spends on theith day

    Output

    Line 1: The smallest possible monthly limit Farmer John can afford to live with.

    Sample Input

    7 5
    100
    400
    300
    100
    500
    101
    400

    Sample Output

    500

    Hint

    If Farmer John schedules the months so that the first two days are a month, the third and fourth are a month, and the last three are their own months, he spends at most $500 in any month. Any other method of scheduling gives a larger minimum monthly limit.

    Source

    MYCode:

    #include<iostream>
    #include<cstring>
    #include<cstdio>
    using namespace std;
    #define MAX 100010
    int v[MAX];
    int sum;
    int n,m;
    int most;
    bool check(int lim)
    {
        int i;
        int s=0;
        int ct=0;
        for(i=1;i<=n;i++)
        {
            if(s+v[i]<=lim)
            s+=v[i];
            else
            {
                ct++;
                s=v[i];
            }
        }
        ct++;
        if(ct<=m)
        return true;
        return false;
    }

    int search()
    {
        int lt=most,rt=sum;
        while(lt<rt)
        {
            int mid=(lt+rt)/2;
            if(check(mid))
            rt=mid;
            else
            lt=mid+1;
        }
        return rt;
    }
    int main()
    {
        while(scanf("%d%d",&n,&m)!= EOF)
        {
            int i;
            sum=0;
            most=-1;
            for(i=1;i<=n;i++)
            {
                scanf("%d",&v[i]);
                sum+=v[i];
                if(v[i]>most)
                most=v[i];
            }
            int ans=search();
            printf("%d\n",ans);
        }
    }

    //63MS
    二分法,复杂度nlogn
  • 相关阅读:
    关于C语言中的绝对值函数
    B. Interesting drink(水题 二分)
    A. Boring Apartments(水题)
    A. FashionabLee(水题)
    A. Collecting Coins(水题)
    A. Fancy Fence(水题)
    最小公因数,最小公倍数,以及快速幂模板
    android:layout_gravity 和 android:gravity 的区别
    Android开发之Intent略解
    java中类的创建及初始化过程
  • 原文地址:https://www.cnblogs.com/java20130725/p/3215880.html
Copyright © 2011-2022 走看看