zoukankan      html  css  js  c++  java
  • POJ1111:Image Perimeters(DFS) java程序员

    Language:
    Image Perimeters
    Time Limit: 1000MS   Memory Limit: 10000K
    Total Submissions: 6691   Accepted: 3976

    Description

    Technicians in a pathology lab analyze digitized images of slides. Objects on a slide are selected for analysis by a mouse click on the object. The perimeter of the boundary of an object is one useful measure. Your task is to determine this perimeter for selected objects. 

    The digitized slides will be represented by a rectangular grid of periods, '.', indicating empty space, and the capital letter 'X', indicating part of an object. Simple examples are 
    XX   Grid 1       .XXX   Grid 2 
    
    XX                .XXX 
    
                      .XXX 
    
                      ...X 
    
                      ..X. 
    
                      X... 

    An X in a grid square indicates that the entire grid square, including its boundaries, lies in some object. The X in the center of the grid below is adjacent to the X in any of the 8 positions around it. The grid squares for any two adjacent X's overlap on an edge or corner, so they are connected. 
    XXX 
    
    XXX    Central X and adjacent X's 
    
    XXX 

    An object consists of the grid squares of all X's that can be linked to one another through a sequence of adjacent X's. In Grid 1, the whole grid is filled by one object. In Grid 2 there are two objects. One object contains only the lower left grid square. The remaining X's belong to the other object. 

    The technician will always click on an X, selecting the object containing that X. The coordinates of the click are recorded. Rows and columns are numbered starting from 1 in the upper left hand corner. The technician could select the object in Grid 1 by clicking on row 2 and column 2. The larger object in Grid 2 could be selected by clicking on row 2, column 3. The click could not be on row 4, column 3. 

    One useful statistic is the perimeter of the object. Assume each X corresponds to a square one unit on each side. Hence the object in Grid 1 has perimeter 8 (2 on each of four sides). The perimeter for the larger object in Grid 2 is illustrated in the figure at the left. The length is 18. 

    Objects will not contain any totally enclosed holes, so the leftmost grid patterns shown below could NOT appear. The variations on the right could appear: 
    Impossible   Possible 
    
    
    
    XXXX         XXXX   XXXX   XXXX 
    
    X..X         XXXX   X...   X... 
    
    XX.X         XXXX   XX.X   XX.X 
    
    XXXX         XXXX   XXXX   XX.X 
    
    
    
    .....        .....  .....  ..... 
    
    ..X..        ..X..  ..X..  ..X.. 
    
    .X.X.        .XXX.  .X...  ..... 
    
    ..X..        ..X..  ..X..  ..X.. 
    
    .....        .....  .....  ..... 

    Input

    The input will contain one or more grids. Each grid is preceded by a line containing the number of rows and columns in the grid and the row and column of the mouse click. All numbers are in the range 1-20. The rows of the grid follow, starting on the next line, consisting of '.' and 'X' characters. 

    The end of the input is indicated by a line containing four zeros. The numbers on any one line are separated by blanks. The grid rows contain no blanks. 

    Output

    For each grid in the input, the output contains a single line with the perimeter of the specified object.

    Sample Input

    2 2 2 2
    XX
    XX
    6 4 2 3
    .XXX
    .XXX
    .XXX
    ...X
    ..X.
    X...
    5 6 1 3
    .XXXX.
    X....X
    ..XX.X
    .X...X
    ..XXX.
    7 7 2 6
    XXXXXXX
    XX...XX
    X..X..X
    X..X...
    X..X..X
    X.....X
    XXXXXXX
    7 7 4 4
    XXXXXXX
    XX...XX
    X..X..X
    X..X...
    X..X..X
    X.....X
    XXXXXXX
    0 0 0 0

    Sample Output

    8
    18
    40
    48
    8

    Source

    MYCode:

    #include<iostream>
    #include<cstring>
    #include<cstdio>
    using namespace std;
    #define MAX 25
    char mat[MAX][MAX];
    bool vis[MAX][MAX];
    int dirt[8][2]={{1,0},{-1,0},{0,1},{0,-1},{1,1},{1,-1},{-1,1},{-1,-1}};
    int n,m;
    int ans;
    void init()
    {
        memset(vis,0,sizeof(vis));
        ans=0;
    }
    void dfs(int x,int y)
    {
        vis[x][y]=1;
        int i;
        int tx,ty;
        for(i=0;i<8;i++)
        {
            tx=x+dirt[i][0];
            ty=y+dirt[i][1];
            bool flag=false;
            if(1<=tx&&tx<=n&&ty>=1&&ty<=m&&mat[tx][ty]=='X')
            {
                if(vis[tx][ty])
                continue;
                flag=true;
                dfs(tx,ty);
            }
            if(flag==false&&i<4)
            {
                ans++;
            }
        }
    }


    int main()
    {
        int x,y;
        while(scanf("%d%d%d%d",&n,&m,&x,&y))
        {
            if(n==0&&m==0&&x==0&&y==0)
            break;
            init();
            getchar();
            int i,j;
            for(i=1;i<=n;i++)
            {
                for(j=1;j<=m;j++)
                {
                    //scanf("%c",&mat[i][j]);
                    cin>>mat[i][j];
                }
            }
            dfs(x,y);
            printf("%d\n",ans);
        }
    }

    //

    采用DFS搜索整个Object.

    难点:统计周长

    方法:如果一个方块的上下左右四个方向任意方向没有'X',周长+1.

  • 相关阅读:
    为什么今日头条是技术牛人收割机(FW)
    独家|浅谈用户行为数据的价值挖掘(PPT)(FW)
    深度学习笔记
    "堕落"的头条,还是"不堪"的民众?
    理解传统企业的问题与困惑
    人工智能在医疗领域究竟要怎么玩?(FW)
    佟崴嵬
    youtube true view的逻辑
    AI第一性原理
    域对象的属性和请求的转发重定向
  • 原文地址:https://www.cnblogs.com/java20130725/p/3215890.html
Copyright © 2011-2022 走看看