Primitive Roots
Time Limit: 1000MS | Memory Limit: 10000K | |
Total Submissions: 2159 | Accepted: 1194 |
Description
We say that integer x, 0 < x < p, is a primitive root modulo odd prime p if and only if the set { (xi mod p) | 1 <= i <= p-1 } is equal to { 1, ..., p-1 }. For example, the consecutive powers of 3 modulo
7 are 3, 2, 6, 4, 5, 1, and thus 3 is a primitive root modulo 7.
Write a program which given any odd prime 3 <= p < 65536 outputs the number of primitive roots modulo p.
Write a program which given any odd prime 3 <= p < 65536 outputs the number of primitive roots modulo p.
Input
Each line of the input contains an odd prime numbers p. Input is terminated by the end-of-file seperator.
Output
For each p, print a single number that gives the number of primitive roots in a single line.
Sample Input
23 31 79
Sample Output
10 8 24
Source
MYCode:
#include<iostream>
#include<cstring>
#include<cstdio>
#include<cmath>
using namespace std;
#define MAX 65550
int prime[MAX];
bool flag[MAX];
int ct;
void pre()
{
memset(flag,0,sizeof(flag));
int i,j;
flag[1]=1;
ct=0;
for(i=2;i*i<=MAX;i++)
{
if(!flag[i])
{
prime[ct++]=i;
for(j=2*i;j<=MAX;j+=i)
{
flag[j]=1;
}
}
}
}
int euler(int x)
{
int res=x;
int i;
for(i=0;prime[i]*prime[i]<=x && i<ct;i++)
{
if(x%prime[i]==0)
{
res=res*1.0/prime[i]*(prime[i]-1);
while(x%prime[i]==0)x/=prime[i];
}
}
if(x>1)res=res/x*(x-1);
return res;
}
int main()
{
int p;
pre();
while(scanf("%d",&p)!=EOF)
{
int ans=euler(p-1);
printf("%d\n",ans);
}
}
//
#include<cstring>
#include<cstdio>
#include<cmath>
using namespace std;
#define MAX 65550
int prime[MAX];
bool flag[MAX];
int ct;
void pre()
{
memset(flag,0,sizeof(flag));
int i,j;
flag[1]=1;
ct=0;
for(i=2;i*i<=MAX;i++)
{
if(!flag[i])
{
prime[ct++]=i;
for(j=2*i;j<=MAX;j+=i)
{
flag[j]=1;
}
}
}
}
int euler(int x)
{
int res=x;
int i;
for(i=0;prime[i]*prime[i]<=x && i<ct;i++)
{
if(x%prime[i]==0)
{
res=res*1.0/prime[i]*(prime[i]-1);
while(x%prime[i]==0)x/=prime[i];
}
}
if(x>1)res=res/x*(x-1);
return res;
}
int main()
{
int p;
pre();
while(scanf("%d",&p)!=EOF)
{
int ans=euler(p-1);
printf("%d\n",ans);
}
}
//
求奇素数的原根:
结论:root=euler(euler(p))=euler(p-1)
euler函数的应用.
如何证明呢?
待定.