zoukankan      html  css  js  c++  java
  • [原]NYOJ-216-A problem is easy

    大学生程序代写

    /*A problem is easy

    时间限制:1000 ms  |  内存限制:65535 KB
    难度:3
    描述
    When Teddy was a child , he was always thinking about some simple math problems ,
    such as “What it’s 1 cup of water plus 1 pile of dough ..” , “100 yuan buy 100 pig” .etc..




    One day Teddy met a old man in his dream , in that dream the man whose name was“RuLai”
     gave Teddy a problem :


    Given an N , can you calculate how many ways to write N as i * j + i + j (0 < i <= j) ?


    Teddy found the answer when N was less than 10…but if N get bigger , he found it was too
    difficult for him to solve.
    Well , you clever ACMers ,could you help little Teddy to solve this problem and let him have
    a good dream ?
    输入
    The first line contain a T(T <= 2000) . followed by T lines ,each line contain an
    integer N (0<=N <= 10^11).
    输出
    For each case, output the number of ways in one line
    样例输入
    2
    1
    3
    样例输出
    0
    1
    上传者
    苗栋栋*/


    /*
    双重循环肯定超时的 直接用一个判断条件能减少时间


    i*j+i+j =N 经过观察,可以变形为i*j+i+j+1=N+1,也就是说,可以进一步变形为(i+1)*(j+1)=N+1


    所以i从2判断到sqrt(n+1)即可
    */
    #include<stdio.h>
    #include<math.h>//不需要long long int
    int main(){
       int m,i;
       scanf("%d",&m);
       while(m--){
    int n;
       scanf("%d",&n);

       int count = 0;

    int s=sqrt(n+1);

    for(i=2;i<=s;++i)
    {
     if((n +1)%i==0)
     count++;
    }
    printf("%d ",count);
    }

    return 0;
    }
    作者:chao1983210400 发表于2013-7-20 12:33:26 原文链接
    阅读:12 评论:0 查看评论
  • 相关阅读:
    SQL Server 存储过程
    SQL数据类型介绍
    XML文件操作指南
    C# 程序集 与 反射
    详解C#中System.IO.File类和System.IO.FileInfo类的用法
    C# 之泛型详解
    C#中HashTable的用法示例2
    C#中HashTable的用法示例1
    DEDECMS5.7 首页和栏目页调用文章按权重排序
    linux创建用户,指定组
  • 原文地址:https://www.cnblogs.com/java20130726/p/3218706.html
Copyright © 2011-2022 走看看