zoukankan      html  css  js  c++  java
  • 两道相似题——watereasy&&Javabeans

    一、Javabeans

    原题:

    Description

    Javabeans are delicious. Javaman likes to eat javabeans very much.

    Javaman has n boxes of javabeans. There are exactly i javabeans in the i-th box (i = 1, 2, 3,...n). Everyday Javaman chooses an integer x. He also chooses several boxes where the numbers of javabeans are all at least x. Then he eats x javabeans in each box he has just chosen. Javaman wants to eat all the javabeans up as soon as possible.  So how many days it costs for him to eat all the javabeans?

    Input

    There are multiple test cases. The first line of input is an integer T ≈ 100 indicating the number of test cases. 

    Each test case is a line of a positive integer 0 < n < 231.

    Output

    For each test case output the result in a single line.

    Sample Input

    4
    1
    2
    3
    4
    

    Sample Output

    1
    2
    2
    3
    

    分析:

    找规律问题~~~

    原码:

    #include<stdio.h>
    #include<math.h>
    int p(int x)
    {
        int sum=0;
        while(x/=2)
        {
            sum++;
        }
        return sum;
    }
    int main()
    {
        int m,n,f;
        scanf("%d",&m);
        while(m--)
        {
            scanf("%d",&n);
            f=p(n);
            printf("%d\n",f);
        }
        return 0;
    }
    
    
    


     

    二、water-easy

    原题:

    Description

    Download as PDF

    Problem A
    Hello World!
    Input:
    Standard Input

    Output: Standard Output

    When you first made the computer to print the sentence “Hello World!”, you felt so happy, not knowing how complex and interesting the world of programming and algorithm will turn out to be. Then you did not know anything about loops, so to print 7 lines of “Hello World!”, you just had to copy and paste some lines. If you were intelligent enough, you could make a code that prints “Hello World!” 7 times, using just 3 paste commands. Note that we are not interested about the number of copy commands required. A simple program that prints “Hello World!” is shown in Figure 1. By copying the single print statement and pasting it we get a program that prints two “Hello World!” lines. Then copying these two print statements and pasting them, we get a program that prints four “Hello World!” lines. Then copying three of these four statements and pasting them we can get a program that prints seven “Hello World!” lines (Figure 4). So three pastes commands are needed in total and Of course you are not allowed to delete any line after pasting. Given the number of “Hello World!” lines you need to print, you will have to find out the minimum number of pastes required to make that program from the origin program shown in Figure 1.

    Figure 1

    Figure 2

    Figure3

    Figure 4

    Input

    The input file can contain up to 2000 lines of inputs. Each line contains an integer N (0<N<10001) that denotes the number of “Hello World!” lines are required to be printed.

    Input is terminated by a line containing a negative integer.

    Output

    For each line of input except the last one, produce one line of output of the form “Case X: Y” where X is the serial of output and Y denotes the minimum number of paste commands required to make a program that prints N lines of “Hello World!”. 

     

     

    Sample Input                             Output for Sample Input

    2

    10

    -1

    Case 1: 1

    Case  2: 4

    原码:

    #include<stdio.h>
    #include<math.h>
    int p(int x)
    {
        int n=0;
        while(x/=2)
        {
            n++;
        }
        return n;
    }
    int main()
    {
        int t,n,count=1;
        while(scanf("%d",&t)!=EOF&&t>=0)
        {
            n=p(t);
            int m=pow(2,n);
            if(m!=t)
                printf("Case %d: %d\n",count++,n+1);
            else printf("Case %d: %d\n",count++,n);
        }
        return 0;
    }
    


  • 相关阅读:
    java设计模式——多例模式
    Java多例模式
    设计模式(四)——多例模式
    IoC是一个很大的概念,可以用不同的方式实现。
    现有的框架实际上使用以下三种基本技术的框架执行服务和部件间的绑定:
    IOC关注服务(或应用程序部件)是如何定义的以及他们应该如何定位他们依赖的其它服务
    IoC最大的好处是什么?
    Java – Top 5 Exception Handling Coding Practices to Avoid
    @Spring MVC请求处理流程
    Spring Bean的生命周期(非常详细)
  • 原文地址:https://www.cnblogs.com/javawebsoa/p/2995489.html
Copyright © 2011-2022 走看看