zoukankan      html  css  js  c++  java
  • Compression

    原题:

    Description

    Let Compression of an integer  a be the sum of all digits of  a and yields another positive integer. It is obvious that if we compress a number for certain finite steps, we will reach a one digit number. You are given a positive integer a and you are asked to output a one digit number which is created by compression of a.
    For instance, if you are given a number 86, after one step of compression, we will reach number 8+6=14 , and after another step of compression, we reach 1+4=5. So, you should write  5 to the output.

    Input

    The number of test cases comes in the first line.  For each test case you are given a positive integer a<=2^31-1

    Output

    For each test case, write one digit number that you will reach after some steps of compression.

    Sample Input

    34311157871

    Sample Output

    731

    分析:

    简单数学题~~

    源码:

    #include<stdio.h>
    int main()
    {
    	long long k,m,n;
    	scanf("%lld",&k);
    	while(k--)
    	{
    		scanf("%lld",&m);
    		while(m/10!=0)
    		{
    			n=m%10;
    			m/=10;
    			m+=n;
    		}
    		printf("%lld\n",m);
    	}
    	return 0;
    }
    


     

  • 相关阅读:
    HTMLTestRunner下载生成报告
    python+selenium+chromewebdriver或Firefox的环境搭建
    unittest单元测试(简单算法题)
    APP测试功能点大全
    selenium元素定位
    博弈问题dp模版
    位运算基本操作
    素数模版
    二分查找模版
    计算机网络重要知识点
  • 原文地址:https://www.cnblogs.com/javawebsoa/p/3078600.html
Copyright © 2011-2022 走看看