zoukankan      html  css  js  c++  java
  • Compression

    原题:

    Description

    Let Compression of an integer  a be the sum of all digits of  a and yields another positive integer. It is obvious that if we compress a number for certain finite steps, we will reach a one digit number. You are given a positive integer a and you are asked to output a one digit number which is created by compression of a.
    For instance, if you are given a number 86, after one step of compression, we will reach number 8+6=14 , and after another step of compression, we reach 1+4=5. So, you should write  5 to the output.

    Input

    The number of test cases comes in the first line.  For each test case you are given a positive integer a<=2^31-1

    Output

    For each test case, write one digit number that you will reach after some steps of compression.

    Sample Input

    34311157871

    Sample Output

    731

    分析:

    简单数学题~~

    源码:

    #include<stdio.h>
    int main()
    {
    	long long k,m,n;
    	scanf("%lld",&k);
    	while(k--)
    	{
    		scanf("%lld",&m);
    		while(m/10!=0)
    		{
    			n=m%10;
    			m/=10;
    			m+=n;
    		}
    		printf("%lld\n",m);
    	}
    	return 0;
    }
    


     

  • 相关阅读:
    第3 章流程控制语句
    第7 章面向对象程序设计
    linux运维常用命令
    第1 章初识Python
    nginx安装与部署
    Linux下软件安装的几种方式
    MAYA 多线程
    Maya pywin32
    python 中调用windows系统api操作剪贴版
    Maya QT interfaces in a class
  • 原文地址:https://www.cnblogs.com/javawebsoa/p/3078600.html
Copyright © 2011-2022 走看看