zoukankan      html  css  js  c++  java
  • poj 2182 Lost Cows

    Time Limit: 1000MS   Memory Limit: 65536K
    Total Submissions: 8260   Accepted: 5269

    Description

    N (2 <= N <= 8,000) cows have unique brands in the range 1..N. In a spectacular display of poor judgment, they visited the neighborhood 'watering hole' and drank a few too many beers before dinner. When it was time to line up for their evening meal, they did not line up in the required ascending numerical order of their brands. 

    Regrettably, FJ does not have a way to sort them. Furthermore, he's not very good at observing problems. Instead of writing down each cow's brand, he determined a rather silly statistic: For each cow in line, he knows the number of cows that precede that cow in line that do, in fact, have smaller brands than that cow. 

    Given this data, tell FJ the exact ordering of the cows. 

    Input

    * Line 1: A single integer, N 

    * Lines 2..N: These N-1 lines describe the number of cows that precede a given cow in line and have brands smaller than that cow. Of course, no cows precede the first cow in line, so she is not listed. Line 2 of the input describes the number of preceding cows whose brands are smaller than the cow in slot #2; line 3 describes the number of preceding cows whose brands are smaller than the cow in slot #3; and so on. 

    Output

    * Lines 1..N: Each of the N lines of output tells the brand of a cow in line. Line #1 of the output tells the brand of the first cow in line; line 2 tells the brand of the second cow; and so on.

    Sample Input

    5
    1
    2
    1
    0
    

    Sample Output

    2
    4
    5
    3
    1
    

    Source

    hpu张燚

    import java.util.LinkedList;
    import java.util.Scanner;
    import java.util.Stack;
    public class Main{
    	/*
    	 * 大概意思:有N头牛,编号1--N,他不知道每头牛的固定位置,他只知道
    	 * 前边有几个比这个位置牛的编号小的牛,求各个牛的位置,输出其编号
    	 */
    	public static void main(String[] args) {
    		Scanner input=new Scanner(System.in);
    		while(input.hasNext()){
    			int n=input.nextInt();
    			LinkedList<Integer> list=new LinkedList<Integer>();
    			for(int i=1;i<=n;i++)
    				list.add(i);
    			Stack<Integer> s1=new Stack<Integer>();
    			while(--n>0)
    				s1.add(input.nextInt());
    			Stack<Integer> s=new Stack<Integer>();
    			while(!s1.isEmpty()){
    				int a=s1.pop();
    				s.push(list.remove(a));
    			}
    			System.out.println(list.getFirst());
    			while(!s.isEmpty())
    				System.out.println(s.pop());
    		}
    	}
    }



  • 相关阅读:
    dmo4解析xml
    myeclise生成webservice客户端代码
    华为QOS原理及配置
    【转载】 Jointwave零延时视频传输for FPGA/ASIC进入军工领域
    【转载】 网络性能测试工具
    【转载】 结构体大小计算
    【转载】 H264的I/P/B帧类型判断
    【转载】 IP实时传输协议RTP/RTCP详解
    【转载】 了解实时媒体的播放(RTP/RTCP 和 RTSP)
    【转载】 CSDN博客与博客园使用对比
  • 原文地址:https://www.cnblogs.com/javawebsoa/p/3233941.html
Copyright © 2011-2022 走看看