zoukankan      html  css  js  c++  java
  • hdu 1027 Ignatius and the Princess II

    Ignatius and the Princess II

    Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
    Total Submission(s): 4625    Accepted Submission(s): 2777


    Problem Description
    Now our hero finds the door to the BEelzebub feng5166. He opens the door and finds feng5166 is about to kill our pretty Princess. But now the BEelzebub has to beat our hero first. feng5166 says, "I have three question for you, if you can work them out, I will release the Princess, or you will be my dinner, too." Ignatius says confidently, "OK, at last, I will save the Princess."

    "Now I will show you the first problem." feng5166 says, "Given a sequence of number 1 to N, we define that 1,2,3...N-1,N is the smallest sequence among all the sequence which can be composed with number 1 to N(each number can be and should be use only once in this problem). So it's easy to see the second smallest sequence is 1,2,3...N,N-1. Now I will give you two numbers, N and M. You should tell me the Mth smallest sequence which is composed with number 1 to N. It's easy, isn't is? Hahahahaha......"
    Can you help Ignatius to solve this problem?
     
    Input
    The input contains several test cases. Each test case consists of two numbers, N and M(1<=N<=1000, 1<=M<=10000). You may assume that there is always a sequence satisfied the BEelzebub's demand. The input is terminated by the end of file.
     
    Output
    For each test case, you only have to output the sequence satisfied the BEelzebub's demand. When output a sequence, you should print a space between two numbers, but do not output any spaces after the last number.
     
    Sample Input
    6 4 11 8
     
    Sample Output
    1 2 3 5 6 4 1 2 3 4 5 6 7 9 8 11 10
     
    #include <iostream>
    #include <stack>
    #include <cstring>
    #include <cstdio>
    #include <string>
    #include <algorithm>
    #include <queue>
    #include <set>
    
    using namespace std;
    /*
    康托展开的的逆过程
    */
    #define ms(arr, val) memset(arr, val, sizeof(arr))
    #define N 10005
    #define INF 0x3fffffff
    #define vint vector<int>
    #define sint set<int>
    const int fac[8] = { 1, 1, 2, 6, 24, 120, 720, 5040 };/*m最大为10000*/
    int ans[N];
    int main()
    {
        int n, m;
        vint v;
        while (cin>>n>>m)
        {
            m--;
            int p = 1;
            v.clear();
            if (n > 8)//1~n-8原样输出
            {
                int i;
                for (i = 1; i <= n - 8; i++)
                {
                    ans[i] = i;
                }
                p = i;
            }
            for (int i = p; i <= n; i++)
            {
                v.push_back(i);
            }
            int t;
            for (int i = n - p; i >= 0; i--)//康拓展开求逆
            {
                t = m / fac[i];
                m %= fac[i];
                ans[p++] = v.at(t);
                v.erase(v.begin() + t);
            }
    
            for (int i = 1; i < n; i++)
            {
                cout << ans[i] << ' ';
            }
            cout << ans[n] << endl;
        }
        return 0;
    }
  • 相关阅读:
    iOS ----------各种判断
    iOS----------常见宏定义
    iOS-----------进阶书籍收藏
    iOS----------YYModel
    Mac 系统占用100g的解决办法
    MAC终端常用语法
    iOS----------网络请求错误
    【2020Python修炼记】前端开发之 CSS基础和CSS选择器
    【2020Python修炼记】前端开发之 HTML常用标签汇总
    【教程干货】前端学习网站·资源
  • 原文地址:https://www.cnblogs.com/jecyhw/p/3897522.html
Copyright © 2011-2022 走看看